Error en mismo EA, mismos parámetros, misma computadora, mismo broker, diferentes resultados

Guerrero-Dragon  

Hola, este error me esta volviendo loco, cuando hice optimizacion de mi robot seleccione los mejores resultados y los corrí para ver la gráfica y guarde los parametros.


Después de un par de días corro los parámetros y me da menos ganancia, pero son los mismos parámetros que guarde y que ya habían dado el resultado anterior y la variacion es enorme de $1618 dls en el primer resultado y depués gana casi la mitad de lo que había ganado.


Ya intenté bajar de nuevo el history data y me di cuenta que esta metiendo menos operaciones y me di cuenta que no tenia data de algunos días en específico, aunque tiene el data desde 1971 pero del 1 al 6 de enero de 2019 no los tenía, borre el MT4 y lo volví a instalar y ahora se saltaba del 10 de octubre de 2018 al 19 de enero del 2019 y por lo tanto no mete todas las operaciones.


Entonces borre todo el history data y corri los gráficos para que se cargue el data, después lo baje con F2 y ya no marca error de que no haya data pero se sigue saltando algunos días, lo he corrido varias veces y de repente consigo los mismos resultados, pero cuando cargo otros parámetros regresa  a suceder lo mismo y ya no se porque el MT4 simplemente hay días que no mete operaciones que ya había metido antes y que cumplen con los parámetros del robot.


Por ejemplo de enero y febrero de 2019 metia 14 operaciones y tengo el reporte con gráfico y las 14 operaciones y después mete solo 9, le bajo el data, actualizao el gráfico y mete 12, desinstalo todo, vuelvo a bajar el data, hago mil cosas y consigo los mismos resulotados pero después otra vez mete menos operaciones.


Ya no se que mas hacer y tampoco entiendo porque hace esto el MT4.


¿Alguna idea?

Victor Manuel Valderrama Zamora  
Guerrero-Dragon:

Hola, este error me esta volviendo loco, cuando hice optimizacion de mi robot seleccione los mejores resultados y los corrí para ver la gráfica y guarde los parametros.


Después de un par de días corro los parámetros y me da menos ganancia, pero son los mismos parámetros que guarde y que ya habían dado el resultado anterior y la variacion es enorme de $1618 dls en el primer resultado y depués gana casi la mitad de lo que había ganado.


Ya intenté bajar de nuevo el history data y me di cuenta que esta metiendo menos operaciones y me di cuenta que no tenia data de algunos días en específico, aunque tiene el data desde 1971 pero del 1 al 6 de enero de 2019 no los tenía, borre el MT4 y lo volví a instalar y ahora se saltaba del 10 de octubre de 2018 al 19 de enero del 2019 y por lo tanto no mete todas las operaciones.


Entonces borre todo el history data y corri los gráficos para que se cargue el data, después lo baje con F2 y ya no marca error de que no haya data pero se sigue saltando algunos días, lo he corrido varias veces y de repente consigo los mismos resultados, pero cuando cargo otros parámetros regresa  a suceder lo mismo y ya no se porque el MT4 simplemente hay días que no mete operaciones que ya había metido antes y que cumplen con los parámetros del robot.


Por ejemplo de enero y febrero de 2019 metia 14 operaciones y tengo el reporte con gráfico y las 14 operaciones y después mete solo 9, le bajo el data, actualizao el gráfico y mete 12, desinstalo todo, vuelvo a bajar el data, hago mil cosas y consigo los mismos resulotados pero después otra vez mete menos operaciones.


Ya no se que mas hacer y tampoco entiendo porque hace esto el MT4.


¿Alguna idea?

Es totalmente normal. Puedes usar el mismo EA, los mismos parametros, las mismas fechas, correr 10 pruebas, y obtener resultados distintos en muchas de ellas. Por este motivo muchos trader profesionales no confian en los backtests del Strategy Tester y prefieren probar la EA durante 3 meses en cuentas demos o de centavos.

Razón de la queja: