Unable to download from market - "MQL5 Market failed download product 'XYZ' [403]"



EA was installed and working fine 

Needed to Update EA

I am logged into a VPS - Windows 2012 R2 Std - fully updated

I am logged into the Community

I have wiped the Metatrader 5 Installed and re-installed

Updated to the latest Metatrader 5 updates

**** still not working *****

Any advice her please would be appreciated. Thanks

This is the post about 403 (about the reasons for this error):

Forum on trading, automated trading systems and testing trading strategies

403 error

Sergey Golubev, 2021.06.29 19:00

error 403 means: no internet access to mql5 internet portal
It may be the following -

1. You did not set your Metatrader in correct way (you should fill Community tab in Metatrader with your forum login and not an email; you should have Internet Explorer the latest version installed on your computer, and in case of MT5 - you should have Windows 64 bit, and more).

2. Your antivirus or firewall is blocking the access to the Market tab and to other services (switch antivirus/firewall off, and find the other antivirus which will not block your access to the Market tab internet).

3. You are using VPS which was blocked by the service (look at the post #19). Yes, some external VPS providers were blocked from the Market by MQ.

4. Your IP was blocked; it may be fake ban because your IP became to be the same with IP of spammer; decision: switch your router with computer to be off and restart them once again - your Ip will be changed in case you are on dynamic IP.


So, if you are external VPS so there are two reasons of this error:

  • your VPS provider was banned from the Market, or
  • your VPS provider installed something on the server with VPS (firewall or any).

Some traders spoke/wrote to VPS provider and the provider fixed it - read post

Error downloading market indicator demo (Error 403 - I don't know how to solve the same problem with my VPS
Error downloading market indicator demo (Error 403 - I don't know how to solve the same problem with my VPS
  • 2021.01.04
  • www.mql5.com
I want to point out that i have two vps and i have the same issue on both. Forexvps support told me that they'd have to install a new windows template on my vps - i backed up my set files and let them do it