Login/Authorization issues with MT5 on Mac

 

Hi there,

I've been using a demo account for paper trading the past months.

I've now been trying to connect additional live and demo accounts by two additional brokers. However, I'm not succeeding in connecting the accounts.

In the attached file there is an example screen shot: MetaQuotes Demo account is the one I've been using so far and it works nicely. But when I try to connect either of the AdmiralMarkets accounts, it just keeps loading without anything happening. No market data is received to charts and the icon of the "person" never turns green. The same is the case with the other broker (not show in the screen shot).

The user name and password are correct. The login works fine on MetaTrader Web platform but not on desktop...


The other screen shot depicts what I can see in the lower right corner. It just keeps loading and loading.


Any idea what to do here?

For conext: I'm using MT5 on Mac.

Cheers,

BetS.

Documentation on MQL5: Constants, Enumerations and Structures / Objects Constants / Chart Corner
Documentation on MQL5: Constants, Enumerations and Structures / Objects Constants / Chart Corner
  • www.mql5.com
Chart Corner - Objects Constants - Constants, Enumerations and Structures - MQL5 Reference - Reference on algorithmic/automated trading language for MetaTrader 5
 
I can’t access to my account on my Mac
 
BetS:
...

The other screen shot depicts what I can see in the lower right corner. It just keeps loading and loading.


Any idea what to do here?

For conext: I'm using MT5 on Mac.

...

It may be something with network scan (access broker's server) - you can mouse click on lower right corner to select the other the other server, for example:

Anyway, I think - it is something with your broker's server (you can ask your broker for support).

 
And read this summary post related to Mac -
I cannot install MT5 on my Mac
I cannot install MT5 on my Mac
  • 2023.02.06
  • www.mql5.com
I cannot install MT5 on my Mac...
 

SOLUTION

Thank you for your responses. Unfortunately none of the suggestions worked but I found my solution eventually and posting it here with the hope that it saves other people some frustration.

What I had been doing so far: Right-click on "Accounts", choosing "Login to trading account", entering my data and... waiting... endlessly. THIS DID NOT WORK.


What actually should be done:

Right-click on "Accounts", choose "+ Open an account", search for your broker in the window that opens, click "Next" and choose "Connect with existing trade account". Enter your login data and choose the right server from drop-down, press "Finish", and your account info + charts should load in 10 sec or so.

To me, choosing "Open an account" sounded illogical as I already had an account with my broker.


For any potential smart-asses feeling inclined to claim that I just entered the server name wrong when doing it manually, I did not. I tried this with 3 different brokers 7 different servers tens of different times and don't think I would make a typo every single time.

Reason: