Download Previous version on Trading Robot (EA)

Sturgis isaac
865
Sturgis isaac  
Hey,guys hows it going


I just wanted to know do any of you wish you could download an older version of a EA or indicator you bought from the marketplace. Because sometimes developers make changes to the EA, in an update and it ends up preforming worst than it was previously . And you have no option to go back to the older version. I find this very in convent, and i was wondering if anyone had this problem as well. Or if anyone may have a solution to this problem. 
Sergey Golubev
Moderator
121879
Sergey Golubev  
There is one solution only - contact with the developer/seller for previous version.
Sturgis isaac
865
Sturgis isaac  
Sergey Golubev:
There is one solution only - contact with the developer/seller for previous version.

True,

But even is the seller/developer agreed and their no guarantee they will. How will you be able to run the old version on you MT4 platform? If the EX4 file has to come from the market place if not, it will not run. Without being downloaded from the market place directly. And the market place will only allow you to download the most recent updated version. 

Sergey Golubev
Moderator
121879
Sergey Golubev  
The seller is not dealing with each client separatedly.
The seller is dealing simultaniously with all of the clients.

And if some clients ask for previous version so the seller can make this version as a new one and place it as an update.
people will download, and after some days - next version ...
Sturgis isaac
865
Sturgis isaac  
Sergey Golubev:
The seller is not dealing with each client separatedly.
The seller is dealing simultaniously with all of the clients.

And if some clients ask for previous version so the seller can make this version as a new one and place it as an update.
people will download, and after some days - next version ...
Very good point.

But everyone may not agree. While they're might be some who feel. The previous version worked better. Others may say that the update version is an improvement. For them

This can all be settled. If mqL5 allowed buyers/costumers. To download which ever version of the EA works best for their own trading strategy

Trying to get all the people to message the developer and ask if he can change the EA back. At the same time while a different group of buyers might be saying please don't change it. (All of this is assuming that the developer is even interested or willing to do so) is a tall order to say the least. 
SkystheLimit 986
3016
SkystheLimit 986  

YES, indeed this is a big issue.


A developer may change an indi quite a bit and as a result, your EA / indi may no longer work as before.


It would be very helpful to be able to download older versions.


MQL, can u do that?

Chui Yu Lui
336
Chui Yu Lui  
Totally agree if there is versioning of EA to be downloaded from customers side. 
However, please keep in mind that if some old EAs are not compatible with latest version of MT4. 
Sturgis isaac
865
Sturgis isaac  
I'm just glad the conversation is finally being brought to the front table. 

MQl why would you not reply? I'm sure you see this. 


As for the old versions not working. For the latest Mt4. Thier multiple EA's on the market place that have not been updated since 2014 that still work perfectly fine.

<Deleted>

 So the argument about old EA/indicators  not working on current mt4 is dead in the water. 



Sergey Golubev
Moderator
121879
Sergey Golubev  
Sturgis isaac:
But your a moderator. 

You can speak to Metaquotes. And make something happen. Tell them the traders want this. Any trader that doesn't. Can simply not download the older version. 

Some traders want, some of them - do not want, and most of them - do not care.

As I see - you are validated seller, so you can send a message to the service desk about it ...

Sergey Golubev
Moderator
121879
Sergey Golubev  
Keith Watford:

Sergey, the last 8 or so posts have been totally off topic.

May I suggest that you move all those posts into a new topic so that the discussion can continue there.

Yes, I deleted.
Muhammad Alif Novaldi
255
Muhammad Alif Novaldi  
SkystheLimit 986:

YES, indeed this is a big issue.


A developer may change an indi quite a bit and as a result, your EA / indi may no longer work as before.


It would be very helpful to be able to download older versions.


MQL, can u do that?

Also it is possible to backup older version before upgrading it?