Disable manual trading when a EA is running

Stefano Piovesan
174
Stefano Piovesan  
Is it possible to disable manual trading (i.e. closing EA opened positions) when the EA is running in order to not interfere with the EA?
Marco vd Heijden
Moderator
13448
Marco vd Heijden  

No.

You code has to be able to deal with that.

john.brave
18
john.brave  
How about the answers from our friends? What is help?
Marco vd Heijden
Moderator
13448
Marco vd Heijden  
It's not possible.
Pimpinela
89
Pimpinela  
You can definitively close opened trades, both manual and automated, from the "Trade" tab, just click on the X at the right most cell of each open trade line. Although that will not disable new trades. It looks to me you're asking two different questions in one.
robert.miner
20
robert.miner  
does anyone in the modification? could possibly be.
lippmaje
1657
lippmaje  
That's most likely an XY problem. I wouldn't bother unless OP clarifies. https://en.wikipedia.org/wiki/XY_problem
XY problem - Wikipedia
  • en.wikipedia.org
The XY problem is a communication problem encountered in help desk and similar situations in which the real issue, X, of the person asking for help is obscured, because instead of asking directly about issue X, they ask how to solve a secondary issue, Y, which they believe will allow them to resolve issue X. However, resolving issue Y often...
oliver1007
34
oliver1007  
The use of EA, or trading robot can be more risky than manual trading, if the robot used is not equipped with a good money management algorithm.
William Roeder
24595
William Roeder  
Stefano Piovesan: Is it possible to disable manual trading (i.e. closing EA opened positions) when the EA is running in order to not interfere with the EA?

Start the EA and then simply minimize the terminal and leave it that way.

Denis Nikolaev
26030
Denis Nikolaev  
If You are concerned about open positions Advisor, You should move away from the monitor and do other things
Anthony Garot
5164
Anthony Garot  
William Roeder:

Start the EA and then simply minimize the terminal and leave it that way.

I love this answer! Succinct and works perfectly!