EA double entry with virtual server

To add comments, please log in or register
barrowclough
35
barrowclough  

Hi, I'm trying out using an MQL5 virtual server for the first time. I synched everything, and now it's entered a double entry for each position.


I am guessing it's because I have Autotrading turned on in my TM4 running on my laptop. I assume that I should turn this off, and that the virtual server has auto trading turned on by default??


Thanks!

Sergey Golubev
Moderator
106091
Sergey Golubev  

Autotrading is always ON in mql5 VPS for MT4/MT5, irrespective off - you turned it ON or OFF during/to synchronize.

Did your EA is trading on your MT4 as well?
if yes so your EA is trading on VPS + on your MT4 ... and it may be double entry ... I am not sure but it is just my idea about it ... 

----------------

How to monitor:

Just watch the following videos here, and the article here: Working with the Virtual Terminal

----------------

and this thread may help - 

How to update/adjust EAs that are hosted on a VPS?

Sergey Golubev
Moderator
106091
Sergey Golubev  

And just for the information - how to subscribe to VPS (you can check all the steps for example):

Forum on trading, automated trading systems and testing trading strategies

missing signal trades

Eleni Anna Branou, 2017.04.10 09:50

Hello Nashy, below are the steps for implementing MQL5 integrated VPS:

1. Go to your account details in the Navigator window of your MT4 platform, right click in your account number or name and select the option Register a Virtual Server.

2. In the Virtual Hosting Wizard window that opens, the VPS with the lower Ping, ms value is presented automatically.

 


 

3. Select your payment plan for 1, 3, 6 or 12 months and click Next.

4. Tick the: I agree to the virtual hosting service rules and the auto renewal option below (if you want) and click Next. 




5. Complete your payment for the VPS Service

6. In the next window, tick the Migrate signal: account and settings option, click End and you are done.




soubra2003
31839
soubra2003  
barrowclough:

Hi, I'm trying out using an MQL5 virtual server for the first time. I synched everything, and now it's entered a double entry for each position.


I am guessing it's because I have Autotrading turned on in my TM4 running on my laptop. I assume that I should turn this off, and that the virtual server has auto trading turned on by default??


Thanks!

I am not sure if I understand your case. But as you said, it is getting two orders because your pc is active as well .. so two sources giving same commands at same moment!
Or maybe you migrated the expert two times.
Try to reset that issue by removing everything from your account then migrate, after that re-attach your expert(s) and re-migrate it/them.
By default, the auto trading will be disabled from your pc (DON'T enable it)
Eleni Anna Branou
Moderator
6580
Eleni Anna Branou  
barrowclough:

Hi, I'm trying out using an MQL5 virtual server for the first time. I synched everything, and now it's entered a double entry for each position.


I am guessing it's because I have Autotrading turned on in my TM4 running on my laptop. I assume that I should turn this off, and that the virtual server has auto trading turned on by default??


Thanks!


Yes, as Sergey pointed out, when you use MQL5 VPS you don't need to keep your local MT4/5 platform open and Auto Trading ON, because you will end up with double trades (as you did).

barrowclough
35
barrowclough  
Sergey Golubev:

Autotrading is always ON in mql5 VPS for MT4/MT5, irrespective off - you turned it ON or OFF during/to synchronize.

Did your EA is trading on your MT4 as well?
if yes so your EA is trading on VPS + on your MT4 ... and it may be double entry ... I am not sure but it is just my idea about it ... 

----------------

How to monitor:

Just watch the following videos here, and the article here: Working with the Virtual Terminal

----------------

and this thread may help - 

How to update/adjust EAs that are hosted on a VPS?


Thanks very much, yes I believe it's being triggered both by the VPS and the MT4 on my PC, I should leave it turned off on my PC. Thanks!

To add comments, please log in or register