I place a take profit but it didn't work can some who has a a bit of knowledge explain

To add comments, please log in or register
calvinmd1
22
calvinmd1  

Im new to Forex on the MT4 platform so this is a demo account, the green arrow is where i placed my sell trade but it ddnt take profit when it hit the take profit line.There are two candlestick that hit my take profit twice so im very confused .Please help


Jack Thomas
1626
Jack Thomas  
calvinmd1:

Im new to Forex on the MT4 platform so this is a demo account, the green arrow is where i placed my sell trade but it ddnt take profit when it hit the take profit line.There are two candlestick that hit my take profit twice so im very confused .Please help


The ticket in the screenshot is a sell order with a 0.98424 TP and the price is 0.98547.

Since the price is still above the take profit, it has no reason to trigger.

Are you taking into consideration what the spread was at that moment? It could be that the spread widened and the closing price didn't touch the TP at the time.

Perhaps send the screenshot to your brokerage and simply ask them about it.

William Roeder
20207
William Roeder  

You buy at the Ask and sell at the Bid. So your sell order's TP/SL, and pending buy orders will be triggered when the Ask reaches it. To trigger at a specific Bid price, add the average spread.

The charts show Bid prices only. Turn on the Ask line to see how big the spread is (Tools -> Options {control-O} -> charts -> Show ask line.)

Kent Slaughter
170
Kent Slaughter  
That was unhelpful... The guy placed a TP, and yes the price is above the TP in the screenshot, but we can see that it was below the TP. I have a similar issue with a TP not firing, and this also didn't help me. If someone knows what might be happening, please share... Is it a common bug with MT4? Weird, when so much money rides on it...
Keith Watford
Moderator
20312
Keith Watford  
illused:
That was unhelpful... The guy placed a TP, and yes the price is above the TP in the screenshot, but we can see that it was below the TP. I have a similar issue with a TP not firing, and this also didn't help me. If someone knows what might be happening, please share... Is it a common bug with MT4? Weird, when so much money rides on it...

What was unhelpful?

The question has been answered in the post above yours. Sell orders are close at Ask. Just because Bid hit the TP level, it doesn't mean that Ask has.

To add comments, please log in or register