MetaEditor ToolBox text size needs microscope to read

Timal
59
Timal  

I cannot get Toolbox Help tab's text to increase in size...

Using MetaEditor ver 4.00 build 202.

The Toolbox (ctrl-T or toolbar icon or place cursor on MQL4 language item and press F1) has a 'Help' tab and the text on this as shown below is unreadable.

Have read somewhere that ControlKey + mouse wheel allows text size to be altered. This does not work for me.

Sure would enjoy hearing from others that have had this issue and solution(s) that worked for them

ThomasB
16
ThomasB  

Select some text in that window, then hold CTRL and scroll with your mouse.

[Deleted]  

I have the opposite problem... in former versions the text was normal, but now it is extremely big and thus unreadable... I tried your advice but it doesn't work.

Timal
59
Timal  

ThomasB: thanks for reply. Best I could get is some text with readable and rest = nano size!

Perhaps sad question - but wonder if 'where' one gets MT from would make difference???

Timal
59
Timal  

(I should have mentioned that sometime ago, the control key + scroll wheel worked for me too - but after many months away from MetaEditor and many new versions of the MT4 package I found myself needing the editor and the latest build does not respond to that scroll wheel action, so I ended up with with this small text issue.

Additionally, I had tried the IE text size action long time ago and did not work [the scroll wheel did work!]. But as explained below, this time around the scroll wheel does not work and the text size action does! all very confusing indeed...) I think that's why I never tried the IE text size action this time around since not ever work for me.

So then, following yet more playing about (I went and installed Alpari's MT - out of desperation and made no difference to the text size at all - but got another demo a/c - lol)

Here is what I did (worked in both MetaQuotes and Alpari installs/editors - well... since same editor build, guess this is to be expected!)

Close editor.

Test:

-I then went to IE (version 7.0.5730.11) the multi tabbed new version. You can change the currently viewed page text size by Control+[keypad Plus or Minus keys]. Note that this is independant to the setting in Toolbar:View > Text Size.

-run editor.

Result:

-the editor's help text size did not change

Close editor.

Test:

-Toolbar:View > Text Size and change to largest.

-run editor.

Result:

-editor's help text size DID become B I G

Summary:

In IE...

- I keep IE's View > Text Size set to medium

- If I need smaller text size on the page I use Ctrl+keypad Minus key.

- If I need larger text size on the page I use Ctrl+keypad Plus key.

In MetaEditor...

- [for me] ToolBox help text size works via IE's View > Text Size setting.

HTH

fxid10t
148
fxid10t  
ukt:
(I should have mentioned that sometime ago, the control key + scroll wheel worked for me too - but after many months away from MetaEditor and many new versions of the MT4 package I found myself needing the editor and the latest build does not respond to that scroll wheel action, so I ended up with with this small text issue.

Additionally, I had tried the IE text size action long time ago and did not work [the scroll wheel did work!]. But as explained below, this time around the scroll wheel does not work and the text size action does! all very confusing indeed...) I think that's why I never tried the IE text size action this time around since not ever work for me.

So then, following yet more playing about (I went and installed Alpari's MT - out of desperation and made no difference to the text size at all - but got another demo a/c - lol)

Here is what I did (worked in both MetaQuotes and Alpari installs/editors - well... since same editor build, guess this is to be expected!)

Close editor.

Test:

-I then went to IE (version 7.0.5730.11) the multi tabbed new version. You can change the currently viewed page text size by Control+[keypad Plus or Minus keys]. Note that this is independant to the setting in Toolbar:View > Text Size.

-run editor.

Result:

-the editor's help text size did not change

Close editor.

Test:

-Toolbar:View > Text Size and change to largest.

-run editor.

Result:

-editor's help text size DID become B I G

Summary:

In IE...

- I keep IE's View > Text Size set to medium

- If I need smaller text size on the page I use Ctrl+keypad Minus key.

- If I need larger text size on the page I use Ctrl+keypad Plus key.

In MetaEditor...

- [for me] ToolBox help text size works via IE's View > Text Size setting.

HTH

Just a word of thanks for your trouble, and solution report. "- [for me] ToolBox help text size works via IE's View > Text Size setting." worked for me also...

Timal
59
Timal  
fxid10t:
Just a word of thanks for your trouble, and solution report. "- [for me] ToolBox help text size works via IE's View > Text Size setting." worked for me also...

Hey... that's great! I know when this all kicked off for me, I was at total crises point , so vgood that you found a workable solution!

But I gotta say that this damn 'issue' is totally freaky because during any longish time period whereby IE is used when the editor is running (when is it not?-lol) the ToolBox text size does the usualreverting back to nanoBot size

Man-o-man... so ok, I have accepted this [sometimes very frequent] text size toggling between unreadable and readable and just 'do the drill' via IE to get readable text size back yet again!

BUT - ya always gotta close MetaEditor down -> do IE text size toggling gunk -> restart MetaEditor.

Course, one looses ALL editor bookmarks, ToolBox Help history and the enevitable brain disruption/work flow

MetaQuotes Inc do not care about this very annoying aspect.

BTW

Every noticed ...\experts\include\stderror.mqh ???

Well sure! most likely readers will have noticed, yes?

Now - consider that MQL syntax has 31char max identifier name length, OK?

With that thought in mind, have another look at stderror.mqh and feast your eyes on the many #defines with >31chars!!!!!

Additionally, try to compile with any of the long'uns and enjoy the compile errors!

Now, to prove that the compiler has internal code that ignores the 31char syntax rule?

Just put something like this in stderror.mqh and compile some source that has "#include "

#define THIS_IS_A_VERY_LONG_IDENTIFIER_NAME_OVER_31_CHARACTERS_AT_60_THIS_IS_

A_VERY_LONG_IDENTIFIER_NAME_OVER_31_CHARACTERS_AT_60 999

Yes I know... but go on - indulge me here!

Above WILL be accepted by compiler - if put in your source - as expected according to syntax rules, the compiler says too long.

Ergo, compiler has code to ignore id length in stderror.mqh and ?other files...

Now ok, I'm overworked bout this but personally, I hate to use constant values - full stop!

Meaning that surprise surprise... I always use #define syntax.

Sure, I gotta type more and the source is larger and sob sob it means that the code is actually readable without having to use my ouija board...

Gosh... that's what macros/defines/whatever your language flavor uses are for!!!

Meaning instead of attempting to figure out what the heck a number is, buried deep in thousands of lines of code [and... btw] just happens to also be peppered all over the many source files etc. that so easily appear when any biggy project progresses.

Now multiply that by potentially hundreds of various constant values plastered all over the project code - sleepless nights are made of this type of coding!

Whereas, have ONE constants file filled with eg, #defines, which at a stroke can be modified FAST 'n EASY, yes?

Ok, am sure you get the picture.

Hitch a ride and go on over to MQL4 Articles: automated forex trading, strategy tester, expert advisors and custom indicators and have a poke about looking at all that code in the numerous articles.

Notice all the hard coded constant values used by these authors???

(burning at the stake type of thoughts continuously cross my mind when reading all that gunk!)

I fully and totally acknowledge the competence of the article authors regarding ideas and methods of implementation associated with the tricky aspects of MT4 Terminal interfacing with respect to Expert Advisors

BUT I do not nor can I condone the blatent and constantly recurring use of downright sloppy coding practices...

Ok then, rant over.

Doooo, have the proverbial 'nice day'