Download MetaTrader 5
To add comments, please log in or register
Have you found an interesting application? Publish it in Code Base - millions of traders will appreciate that!
Dominic Gilbert
1632
Dominic Gilbert 2014.09.17 22:09 

I'm experiencing a strange issue?

Like most on here, I have a designated MT4 offline back-testing platform. Weird thing is, when I boot up the MT4 platform for the first time, if I try to do a fresh back-test of an EA it won't place any trades or if it does it seems to drop out loads that it should have taken at the beginning!?

Although, I can see my comments being accurately updated which is odd.

What I have to do to get it working is then run a back-test of an EA that buys and sells at the market. I stop that, then revert back to my EA that I originally wanted. 

It then works :s !?


See this video: http://screencast.com/t/pJzilCC4ZOf

 

Let me know if I am missing something, i usually do :P 

Keith Watford
Moderator
8017
Keith Watford 2014.09.18 01:27  
DomGilberto:

 I have a designated MT4 offline back-testing platform. Weird thing is, when I boot up the MT4 platform for the first time, if I try to do a fresh back-test of an EA it won't place any trades or if it does it seems to drop out loads that it should have taken at the beginning!?

If the platform is offline, how does it download symbol history data?
Dominic Gilbert
1632
Dominic Gilbert 2014.09.18 08:31  
I import all the 1 minute bars and then I use the Period Converter script.

Strange isn't it :s?
Dominic Gilbert
1632
Dominic Gilbert 2014.09.21 13:02  
Any one else have an opinion from the video I posted above? It's really odd!?

Sometimes I'll also be backtesting and the results are SOOOOO different :s!? No parameters or code changed?
Dominic Gilbert
1632
Dominic Gilbert 2014.09.21 17:31  
I'm now getting randomly "Global Initialization failed"???
/
To add comments, please log in or register