Download MetaTrader 5

UseCloud=1 within configuration file

To add comments, please log in or register
pvo2
64
pvo2  

Hi,

In automating the optimization process for a handful of currency pairs, I have created a configuration file (.ini) for each optimization exercise which includes the UseCloud=1 reference so that the Cloud network is activated. However, when running the configuration file the Cloud is not activated as expected. I have tried rearranging the order of the reference such that UseCloud=1 comes before ShutdownTerminal=1 but makes no difference. Has anyone experienced this issue? If so, can you kindly advise how the problem can be overcome. Listed below is an example of the configuration file.

Thanks in advance.

PV 

--------------------------------------------------------------


[Common]
Login=xxxx
Password=xxxx
ProxyEnable=0
ProxyType=0
ProxyAddress=0
ProxyLogin=10
ProxyPassword=10
KeepPrivate=1
NewsEnable=1
CertInstall=1
 
[Experts]
AllowLiveTrading=0
AllowDllImport=0
Enabled=0
Account=0
Profile=0
 
;+--------------------------------------------------------------------------------
;| Start testing or optimization of the specified Expert Advisor |
;+--------------------------------------------------------------------------------
[Tester]
;--- The EA is located in terminal_data_directory\MQL5\Experts\
Expert=Breakout_EA
;--- The EA start parameters terminal_installation_folder\tester\Presets\
ExpertParameters=Breakout_EA.set
;--- The symbol for testing/optimization
Symbol=AUDUSD
;--- The timeframe for testing/optimization
Period=Daily
;--- Initial deposit
Deposit=10000
;--- Leverage for testing
Leverage=1:100
";--- The ""1 minute OHLC"" mode"
Model=1
;--- Execution of trade orders with a random delay
ExecutionMode=0
;--- Genetic optimization This is what triggers the error if it is set to anything but 0
Optimization=2
;--- Optimization criterion - Maximum balance drawdown value
OptimizationCriterion=0
;--- Start and end dates of the testing range
FromDate=2000.01.01
ToDate=2012.12.31
;--- Custom mode of forward testing
ForwardMode=3
;--- Start date of forward testing
ForwardDate=0
;--- A file with a report will be saved in terminal_installation_folder
Report=Optimisation - TF AUDUSD Daily 2000.01.01 - 2012.12.31 (1)_Breakout
";--- If the specified report already exists, it will be overwritten"
ReplaceReport=1
;--- Set automatic terminal shutdown upon completion of testing/optimization
ShutdownTerminal=1
UseCloud=1
 

Documentation on MQL5: Standard Constants, Enumerations and Structures / Trade Constants / Trade Operation Types
Documentation on MQL5: Standard Constants, Enumerations and Structures / Trade Constants / Trade Operation Types
  • www.mql5.com
Standard Constants, Enumerations and Structures / Trade Constants / Trade Operation Types - Documentation on MQL5
pvo2
64
pvo2  

Hi - Is anyone able to help? I've been looking for a solution over the past couple of days but am having difficulties finding one.

Cheers. 

Alain Verleyen
Moderator
31182
Alain Verleyen  
pvo2:

Hi - Is anyone able to help? I've been looking for a solution over the past couple of days but am having difficulties finding one.

Cheers. 

Did you read this topic https://www.mql5.com/en/forum/13468 ?
Simon Gniadkowski
Moderator
18003
Simon Gniadkowski  
pvo2:

Hi - Is anyone able to help? I've been looking for a solution over the past couple of days but am having difficulties finding one.

Cheers. 

Does it work when you don't try to use the cloud ?
pvo2
64
pvo2  

Angevoyageur - Yes I've been through that forum and also http://www.pssforex.com/index.php/support/mt5_support/configuration_file but can't find any mention about difficulties of using the cloud or any additional requirements other than including the "UseCloud=1" syntax in the configuration file.

RaptorUK - I've tried to do the following 1) disable the cloud and run the configuration file (without "UseCloud=1" syntax) 2) enable the cloud within the terminal but not include the "UseCloud=1" in the config file 3) enable the cloud within the terminal and also include the "UseCloud=1" in the config file. Also 3 scenarios didn't work.

More generally, there must be something simple that I am missing. I assume there are others that have no issues having the cloud running during a batch optimization job? Do you guys experience any issues using the cloud during a batch job? It is indeed a mystery! 

PSS FOREX | MT5 Support | User Guide | FAQs
  • www.pssforex.com
A client terminal can be started with a custom set of parameters. To do it, create a custom file of settings on the basis of the original common.ini file. To start the terminal with this file of settings, execute the following command in the command line: Custom configuration files are used in the "read only" mode during the work of the...
To add comments, please log in or register