Download MetaTrader 5
To add comments, please log in or register
Need mobile version of MetaTrader 5? Download it and trade!
goocreations
329
goocreations 2014.09.23 08:08 
I want to launch an automated optimization of my EA by starting the terminal through command line with a custom config file. Since my PC is not very powerful, I want to use the cloud for the process. If I start the terminal without optimization, that is starting it normally or starting it via command line with my EA on auto trading, the cloud shows up as "allow to use cloud". However, if I specify that optimization should start, the cloud is set to "not allowed to use" and I have to manually set "allow to use cloud" again. Here is my custom config file:
[Common]
Login=1777000
NewsEnable=0
Password=<password>
Server=access.metatrader5.com

[Email]
Enable=0

[Events]
Enable=0

[Experts]
AllowDllImport=1
AllowLiveTrading=1
Enabled=1

[Ftp]
Enable=0

[Notification]
Enable=0

[Tester]
Deposit=100000
ExecutionMode=0
Expert=myea.ex5
ExpertParameters=parameters.set
ForwardMode=0
FromDate=2014.09.15
Leverage=1:100
Model=0
Optimization=2
OptimizationCriterion=0
Period=M5
Symbol=EURUSD
ToDate=2014.09.22
UseCloud=1
UseLocal=1
UseRemote=0
If the optimization terminal starts, you can see that the cloud is set to allowed, but shortly after starting it gets automatically disbaled by MT. I've also tried to add MQL5Login and MQL5Password to the config, but that didn't help either. Specifically if you add the following option to your config file, the cloud is automatically set to "not allowed":

Optimization=2
Is this a bug in MT5? Why does it not use the option "UseCloud" in my config file?
/
To add comments, please log in or register