Download MetaTrader 5

Issue with slowness in Editor after upgrading to build 600+

To add comments, please log in or register
Find out how to use widgets at MQL5.community
asmallrabbit
32
asmallrabbit 2014.03.02 18:40 

Hello, ever since upgrading to build 600+ and the new editor, I've been experiencing horrible delays when coding. Previously it worked just fine, but now when I'm typing in the editor there will be a delay of up to 30 seconds before what I typed actually appears. The odd part is that it seems to be worse towards the top of my code and then is not as bad when i'm near the bottom.


I thought it might have to do with the new save location so I turned off UAC (windows 7 64) and saved in back in the original installation directory but its not any better.

Any ideas how i can fix this?

Alain Verleyen
Moderator
30752
Alain Verleyen 2014.03.02 20:42  
asmallrabbit:

Hello, ever since upgrading to build 600+ and the new editor, I've been experiencing horrible delays when coding. Previously it worked just fine, but now when I'm typing in the editor there will be a delay of up to 30 seconds before what I typed actually appears. The odd part is that it seems to be worse towards the top of my code and then is not as bad when i'm near the bottom.


I thought it might have to do with the new save location so I turned off UAC (windows 7 64) and saved in back in the original installation directory but its not any better.

Any ideas how i can fix this?

Can you check the load of your CPU ? If it's high which process(es) use it ?
asmallrabbit
32
asmallrabbit 2014.03.03 00:24  
angevoyageur:
Can you check the load of your CPU ? If it's high which process(es) use it ?


When i'm not typing in the editor it's (metaeditor.exe according to the resource monitor in windows7) using no resources. As soon as i start typing there is a delay in which it spikes the usage until I stop typing and the text actually appears after which it drops again. It seems that as long as I keep typing the usage keeps rising and the text will never appear because it can't seem to catch up. I went as high as 15% CPU usage for just metaeditor, this is typing just random characters (like 80 or so) and until the text appears the Editor is completely unresponsive. I never had an issue with the editor keeping up to my typing before the update.

Otherwise overall CPU usage according to windows task manager is no more then 5%, when typing in metaeditor it goes to 15%.

Also, this is only the case when I'm typing closer to the "top" of my file. If i type near the end, it seems to have no problem keeping up and the usage doesn't climb higher then 1-2%. The file is 6000+ lines long if that makes a difference. But again, it wasn't exhibiting this delay before the upgrade.

Alain Verleyen
Moderator
30752
Alain Verleyen 2014.03.03 00:37  
asmallrabbit:


When i'm not typing in the editor it's (metaeditor.exe according to the resource monitor in windows7) using no resources. As soon as i start typing there is a delay in which it spikes the usage until I stop typing and the text actually appears after which it drops again. It seems that as long as I keep typing the usage keeps rising and the text will never appear because it can't seem to catch up. I went as high as 15% CPU usage for just metaeditor, this is typing just random characters (like 80 or so) and until the text appears the Editor is completely unresponsive. I never had an issue with the editor keeping up to my typing before the update.

Otherwise overall CPU usage according to windows task manager is no more then 5%, when typing in metaeditor it goes to 15%.

Also, this is only the case when I'm typing closer to the "top" of my file. If i type near the end, it seems to have no problem keeping up and the usage doesn't climb higher then 1-2%. The file is 6000+ lines long if that makes a difference. But again, it wasn't exhibiting this delay before the upgrade.

I suggest you to report this to ServiceDesk of Metaquotes (you have to register on mql5.com).
KoliEr Li
123
KoliEr Li 2014.05.28 18:16  

I think this is the issue to new Intel i7 CPU, at least this happen to my new build gig. If file get up to 1000 lines, MetaEditor would become very slow to input characters. 

Alain Verleyen
Moderator
30752
Alain Verleyen 2014.05.28 19:20  
kolier:

I think this is the issue to new Intel i7 CPU, at least this happen to my new build gig. If file get up to 1000 lines, MetaEditor would become very slow to input characters. 

Maybe. Did you already try the build 654 (beta) ?
SYED NAUFAL GADDAFI
1401
SYED NAUFAL GADDAFI 2014.05.29 04:07  
It is working fine on my AMD cpu though. 2k plus lines of code and responded normally.
KoliEr Li
123
KoliEr Li 2014.05.30 19:23  
angevoyageur:
Maybe. Did you already try the build 654 (beta) ?


I've added MetaQuotes-Demo server and open an account and do the upgrade.

MetaEditor is version 5, build 944, this issue still exist.

deysmacro:
It is working fine on my AMD cpu though. 2k plus lines of code and responded normally.

Yeah, my Phenom II x 6 has no problem with it, but the latest built rig with i7 4820K do have the same issue stated by @asmallrabbit.

And from his reply, I can judge that he's using i7 4 cores 8 threads CPU as well. 

Alain Verleyen
Moderator
30752
Alain Verleyen 2014.05.31 19:00  
kolier:


I've added MetaQuotes-Demo server and open an account and do the upgrade.

MetaEditor is version 5, build 944, this issue still exist.

Yeah, my Phenom II x 6 has no problem with it, but the latest built rig with i7 4820K do have the same issue stated by @asmallrabbit.

And from his reply, I can judge that he's using i7 4 cores 8 threads CPU as well. 

You have to report that to ServiceDesk.
KoliEr Li
123
KoliEr Li 2014.05.31 23:26  
angevoyageur:
You have to report that to ServiceDesk.


I think the dev team would pay attention on the forum as well, and I think it will need some more users to give proof, this kind of bug may not be easy to find to fix.
Ian Venner
2584
Ian Venner 2014.06.01 01:43  

Have you checked your RAM usage while this is occuring ?

12
To add comments, please log in or register