Download MetaTrader 5
To add comments, please log in or register
Have you found an error in our products? Apply to Service Desk!
FaceNord
18
FaceNord 2014.02.17 17:56 

Backtesting my EA under 509 gives me 2000 orders and no error messages.

Backtesting the very same EA under 610 gives me 2 orders and a bench of "tester : 0 symbol not found".

The backest procedures were the same: I used the strategy tester window. I did not see the use of the market watch.

The pair is EURUSD.

What should I do? When I compile my EA, I get 0 error, 0 warning.


PS: Worse, all my 7 EAs are out of order: 2,5 years of work !!!!!

Ubzen
Moderator
5394
Ubzen 2014.02.17 18:37  
FaceNord:

Backtesting my EA under 509 gives me 2000 orders and no error messages.

Backtesting the very same EA under 610 gives me 2 orders and a bench of "tester : 0 symbol not found".

The backest procedures were the same: I used the strategy tester window. I did not see the use of the market watch.

The pair is EURUSD.

What should I do? When I compile my EA, I get 0 error, 0 warning.

Double-check your symbol names.

Use Print() to see which lines of codes gets executed and which doesn't.

Make sure you have data for the symbol under testing.

===============================================

Additional problems ... Post your code.

Contact the Service Desk.

Keith Watford
Moderator
7896
Keith Watford 2014.02.17 19:28  
Do not use 0 for the chart symbol, use NULL
FaceNord
18
FaceNord 2014.02.17 19:41  

Thanks Gumrai

I checked the OrderSend orders. The first parameter is : Symbol().

Is there other places, orders, I should check to find the annoying 0 ?

Sincerely.

Alain Verleyen
Moderator
28536
Alain Verleyen 2014.02.17 19:57  
FaceNord:

Thanks Gumrai

I checked the OrderSend orders. The first parameter is : Symbol().

Is there other places, orders, I should check to find the annoying 0 ?

Sincerely.


A lot of places, try to search on "(0". Symbol is always the first in parameter list.
julianmql4
5
julianmql4 2014.03.12 17:47  

Hi,

I am facing the same problem. Did you solved it. If so please help me.Thanks.

Alain Verleyen
Moderator
28536
Alain Verleyen 2014.03.12 18:21  
Julek:

Hi,

I am facing the same problem. Did you solved it. If so please help me.Thanks.

The solution is posted above. Post your code if you need help.
/
To add comments, please log in or register