Download MetaTrader 5

Can i code with the new Metatarder 4 same like before?

To add comments, please log in or register
Tradeing Trader
573
Tradeing Trader  

Hi,

today i did wonder little bit because the Metaeditor have change, when i click compilere my old EA code does not get compilere. Can i not use any more the old codeing language and the old editor?

Simon Gniadkowski
Moderator
18056
Simon Gniadkowski  
PlanandTrade:

Hi,

today i did wonder little bit because the Metaeditor have change, when i click compilere my old EA code does not get compilere. Can i not use any more the old codeing language and the old editor?

Yes you can . . . please show some of your code.
Tradeing Trader
573
Tradeing Trader  
Hello, how can i code like before? how can i use the old meta editor? I think you dont need really to see my code or? because it is a very simple mql4 code, the problem is just that in the new metaeditor everythink looks different and when i click the "compiliere" button in the new editor, then it dont show me the messages no error, and such thinks, it does write me the message "cannot create interface of MQL compiler"
Simon Gniadkowski
Moderator
18056
Simon Gniadkowski  
PlanandTrade:
Hello, how can i code like before? how can i use the old meta editor? I think you dont need really to see my code or? because it is a very simple mql4 code, the problem is just that in the new metaeditor everythink looks different and when i click the "compiliere" button in the new editor, then it dont show me the messages no error, and such thinks, it does write me the message "cannot create interface of MQL compiler"
Pity you didn't put that in your first post . . . are you using Avira AntiVirus ? read this https://forum.mql4.com/60417/page4#899761 and the folloing posts.
Tradeing Trader
573
Tradeing Trader  
yes i am using Avira Anitvirus, i will read that, thank you for the info.
Tradeing Trader
573
Tradeing Trader  

Hello again, i think i have another problem, in the link they discuss because of upgrade problems, but my MT4 is already upgrade, i have already the newest version build 600.

I have atatch a picture below where you can see what for a error message i get from the editor.

I would be happt when somebody can give advise how to slove this.

Simon Gniadkowski
Moderator
18056
Simon Gniadkowski  
PlanandTrade:

Hello again, i think i have another problem, in the link they discuss because of upgrade problems, but my MT4 is already upgrade, i have already the newest version build 600.

I have atatch a picture below where you can see what for a error message i get from the editor.

I would be happt when somebody can give advise how to slove this.

You haven't attached an image . . .

Tradeing Trader
573
Tradeing Trader  
here is a link to the picture, it looks like attachment have not work: https://imagizer.imageshack.us/v2/800x432q90/713/c2wu.png
Tradeing Trader
573
Tradeing Trader  

Here is also the picture as upload

Simon Gniadkowski
Moderator
18056
Simon Gniadkowski  
PlanandTrade:

Here is also the picture as upload

It's a DLL issue, the DLL has not been registered due to your Antivirus. You can set an exception in your Antivirus, then install a new copy of MT4 to a new temporary folder and get it updated to build 600, this should allow the DLL to be registered and your original install of MT4 and MetaEditor should then work.
Tradeing Trader
573
Tradeing Trader  
it would be helpfull when somebody can show how to activate the use of the mql.dll in the Antivirus Software.
12
To add comments, please log in or register