Two Brokers - 1 EA - can you guess - One reluctant to open orders

To add comments, please log in or register
MXVC VII LCXVI   the 3rd
48
MXVC VII LCXVI the 3rd  

Anyone have a suggestion?

I have my trusty EA - on ONE machine running against two brokers - at the same time.

Started @ NZ open Sunday (Monday) and running since (about 48 + hours)

One has Profit of $125 the other $6 (-well, I'm testing at 0.001)

(A) The profitable one opens with the correct value in TP - the other OPENs with tp=0

- Yes, I've verified that the value is correct.

I've thin'ed the code to ONLY perform an OPEN to BUY or OPEN to Sell - otherwise it never sends data to the server.


(B) the Profitable one opens trades by itself - the other just sits and watches.


Note: One is IBFX one is Alpari - Are both of these brokers - EA Friendly? ( They *SAY * that they are.


Oh, and one other thing...

The moment I change the EA Properties to MANUALLY ASK for Permission to Place a Trade...

Then it IMMEDIATELY askes for permission.

Otherwise it sits and waits.


ps, Have confirmed the above on a second machine (same set-up)


Please advise

Ubzen
5299
Ubzen  

(A) The profitable one opens with the correct value in TP - the other OPENs with tp=0

How about 0 SL as some of these brokers need you do submit the order without a TP and SL which you would set later when the order fills

MXVC VII LCXVI   the 3rd
48
MXVC VII LCXVI the 3rd  
ubzen:

(A) The profitable one opens with the correct value in TP - the other OPENs with tp=0

How about 0 SL as some of these brokers need you do submit the order without a TP and SL which you would set later when the order fills.

MXVC VII LCXVI   the 3rd
48
MXVC VII LCXVI the 3rd  
MXVC.VII.LCXVI:



ubzen:

(A) The profitable one opens with the correct value in TP - the other OPENs with tp=0

How about 0 SL as some of these brokers need you do submit the order without a TP and SL which you would set later when the order fills.


Yes,

The code is designed for that exact condition - First it opens the order (with or without sl,tp -> set in parameters) and then MODIFIES the order in-order to update the TP (esp. good with trailing stops).


During these tests, I've disabled the MODIFY ORDER code and just allowing the OPEN order to set the sl=0 and the TP = (calculated value).


I -am- thinking if simply running with exactly whatyou suggest; OPEN the order with 0,0 and then quickly MODIFY'ing the order to add tp.

What worries me is the fact that the code works beautifly - on ONE broker.

$131.80 vs $13.59 on the other. - Both are Placing Trade-Orders, but only one is placing orders with TP>0

MXVC VII LCXVI   the 3rd
48
MXVC VII LCXVI the 3rd  
MXVC.VII.LCXVI:


Yes,

The code is designed for that exact condition - First it opens the order (with or without sl,tp -> set in parameters) and then MODIFIES the order in-order to update the TP (esp. good with trailing stops).


During these tests, I've disabled the MODIFY ORDER code and just allowing the OPEN order to set the sl=0 and the TP = (calculated value).


I -am- thinking if simply running with exactly whatyou suggest; OPEN the order with 0,0 and then quickly MODIFY'ing the order to add tp.

What worries me is the fact that the code works beautifly - on ONE broker.

$131.80 vs $13.59 on the other. - Both are Placing Trade-Orders, but only one is placing orders with TP>0


Oh oh Oh ! Could Be So !!!!

TNX !



MXVC VII LCXVI   the 3rd
48
MXVC VII LCXVI the 3rd  
ubzen:

(A) The profitable one opens with the correct value in TP - the other OPENs with tp=0

How about 0 SL as some of these brokers need you do submit the order without a TP and SL which you would set later when the order fills.


MXVC VII LCXVI   the 3rd
48
MXVC VII LCXVI the 3rd  
ubzen:

(A) The profitable one opens with the correct value in TP - the other OPENs with tp=0

How about 0 SL as some of these brokers need you do submit the order without a TP and SL which you would set later when the order fills.


Uzben,

I modified the code to that now, where I only had the OPEN ... statement

OPEN ...

I now have both the open and modify statements.

OPEN ... 0,0
MODIFY ... 0,value

I'll watch this tonight.


It still doesn't seem to OPEN any orders as it "should"

The moment I goto EA->Properties-> and check [x] the box
for "Ask Manual Confirmation"

Then it IMMEDIATELY ! asks permission (again and again)

-If I refuse and UN-Check the [] box, then it just sits and waits.

Any suggestions?
Ubzen
5299
Ubzen  
I suggest you print or alert as many market-info proprieties as you can. You're looking to see any difference between the two brokers. Example Point value. If there's a difference then you wanna double check if your program is handling the differences effectively.
qjol
3200
qjol  
MXVC.VII.LCXVI:

(B) the Profitable one opens trades by itself - the other just sits and watches.


you tried to check GetLastError() ?
AIRAT SAFIN
1421
AIRAT SAFIN  
Phillip
803
Phillip  
MXVC.VII.LCXVI:

Note: One is IBFX one is Alpari - Are both of these brokers - EA Friendly? ( They *SAY * that they are.



There's nothing to be suspicious about in regards to your EA's performing with these brokers. They are good. If you see a difference then there is something in your EA's that you are not fully accounting for as a difference between the brokers.
12
To add comments, please log in or register