To code base moderator

To add comments, please log in or register
Hazem
42
Hazem  
Two days ago, I added a new indicator to the code base section under the name FX5_MACD_Divergence. After a while I recieved complians because the indicator doesn't draw lines in the indicator window.

The indicator was working correctly under my system. So I downloaded the indicator to see where is the problem. It was a surprise to find that the moderartor in his effort to make the code more cosmotically acceptable he made change in the code which caused this bug.

So how is it possible to correct this bug? I am afraid I add a new version and the whole thing happens again.

This is where the bug located:
   int indicatorWindow = WindowFind("FX5_MACD_Divergence_v1.0(" + 
                                    fastEMA + "," + slowEMA + "," + 
                                    signalSMA + ")");
while it should be:

   int indicatorWindow = WindowFind("FX5_MACD_Divergence_v1.0(" + 
                                    fastEMA + ", " + slowEMA + ", " + 
                                    signalSMA + ")");
By adding a space after the comma inside the quoted, or changing the indiator short name.
MetaQuotes
Moderator
216415
MetaQuotes  
Already fixed. Sorry for our mistake.

'FX5_MACD_Divergence'
TradeX
3
TradeX  

Hi,

I am new though, talking about FX5 Divergence it's an excellent propositions using MT4 . Added Sound Alerts, SMS and / or email could be additional helps. Can you suggest which is best to use sinceyou are showing a few of them. Don't you think Stochastic 25,3,3 & 9,3,3 with 1Hr & 10M time frame to give excellent divergence ALARMS / SIGNALS !!!

Your TradeFX7

paulv
5
paulv  
FX5 wrote >>
Two days ago, I added a new indicator to the code base section under the name FX5_MACD_Divergence. After a while I recieved complians because the indicator doesn't draw lines in the indicator window.

The indicator was working correctly under my system. So I downloaded the indicator to see where is the problem. It was a surprise to find that the moderartor in his effort to make the code more cosmotically acceptable he made change in the code which caused this bug.

So how is it possible to correct this bug? I am afraid I add a new version and the whole thing happens again.

This is where the bug located:
while it should be:

By adding a space after the comma inside the quoted, or changing the indiator short name.

On the version 1.1 when does the arrow actually appear? Is it on the close of the bar that has the arrow under or above it or does the arrow appear after the close of the following bar?

Thanks

leoguisanchez
20
leoguisanchez  

Hello Hazem,

You code returns quite very good signals, but for some reason is not working with MT2 Trading plataform.

Any idea way? I have tried to test it using BT Tester on MT4 using buffers 0 and 1. Looks great.


But when I try to use MT2 connector, nothing happens.

i have send to you na private message as well.


Regards

To add comments, please log in or register