"extern string ..." manchmal Inhalt entfernt

 

Hallo,

mir ist schon mehrmals aufgefallen, dass im Fenster mit den externen Variablen (MT4 Chart --> klick auf Smiley) bei String-Variablen manchmal der Inhalt fehlt, obwohl dieser im Code vorhanden ist. 

Die Variablen werden dann einfach leer angezeigt. Das geschieht nur manchmal, und auch bei verschiedenen EA's und ohne erkennbaren Zusammenhang mit irgendwas.

Beispiel:

im Code:

extern string  s1     = "-------------   Time Settings --------";
extern string  Start_EU             = "09:00";
extern string  Ende_EU              = "11:30";

Im Fenster


Habt Ihre eine Idee, woran das liegen könnte?

Gruß Werner

 

Probier es mal mit input anstelle von extern. das ist die modernere Varionte

Probiere auch das neue input group

input goup   "-------------   Time Settings --------"
input string  Start_EU = "09:00";
input string  Ende_EU  = "11:30";
input group habe ich allerdings im MT4 noch nicht getestet. Bitte berichte ob es funktioniert.
 
Otto Pauser:

Probier es mal mit input anstelle von extern. das ist die modernere Varionte

Probiere auch das neue input group

input group habe ich allerdings im MT4 noch nicht getestet. Bitte berichte ob es funktioniert.

Was hat inout group in mt5 für auswirkungen otto?

 
amando:

Was hat inout group in mt5 für auswirkungen otto?

Im Tester kannst du die ganze Gruppe zum Optimieren ein- und ausschalten (ist eher fragwürdig, wie so manches von MQ). Das stand auch irgendwo in einer Ankündigung.

Aber sonst ist es recht brauchbar um Gruppen von Parametern optisch zu trennen ohne viele Verrenkungen mit Variablennamen.

Übrigens:

Im Tester wurde was verbessert: Er springt jetzt nach dem betätigen des 'StartButtons' nicht mehr auf unerwünschte Tabs, sondern bleibt auf dem aktuellen!

Unglaublich was man mit dem Weglassen von Blödsinn alles verbessern kann!

 
Otto Pauser:

Probier es mal mit input anstelle von extern. das ist die modernere Varionte

Probiere auch das neue input group

input group habe ich allerdings im MT4 noch nicht getestet. Bitte berichte ob es funktioniert.

Danke, Otto. Das werde ich testen. Kann allerdings wieder ein paar Tage dauern, bis der Fall auftritt. Oder auch nicht.

Sobald das gleiche Problem wieder auftritt, melde ich mich wieder auf diesen Post. Ansonsten dürfte es gelöst sein.

Danke!

Gruß

Werner

 
Otto Pauser:

Im Tester kannst du die ganze Gruppe zum Optimieren ein- und ausschalten (ist eher fragwürdig, wie so manches von MQ). Das stand auch irgendwo in einer Ankündigung.

Aber sonst ist es recht brauchbar um Gruppen von Parametern optisch zu trennen ohne viele Verrenkungen mit Variablennamen.

Übrigens:

Im Tester wurde was verbessert: Er springt jetzt nach dem betätigen des 'StartButtons' nicht mehr auf unerwünschte Tabs, sondern bleibt auf dem aktuellen!

Unglaublich was man mit dem Weglassen von Blödsinn alles verbessern kann!

Danke, die funktion kannte ich noch nicht, werd ich gleich testen

Grund der Beschwerde: