Скачать MetaTrader 5

почему могут не работать советники в более поздних релизах Metatrader4

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Forex Trader
114280
Forex Trader  
Здравствуйте, может кто сталкивался с такой проблемой, советник написанный на 175 релизе МТ4, отлично работает и тестируется на этом же релизе, а на 186 уже сливает.
Forex Trader
114280
Forex Trader  
на этом же 175 релизе советник прибыльно торгует на демо, я начал разрабатывать его на 175 релизе потому-что ДЦ (Liteforex.org) на котором я собирался работать распологало только этим релизом терминала,
а сейчас когда пытаюсь протестировать на 186 терминале ДЦ Альпари, советник не работает хотя я тестирую его на в тех-же условиях (инструмент, ТФ 1М и т.д.)
Forex Trader
114280
Forex Trader  
А сделок много?
Если много, то разница в спрэде может повлиять. У лайтов на евру, например, спрэд меньше, чем в альпари.
Forex Trader
114280
Forex Trader  
А сделок много?
Если много, то разница в спрэде может повлиять. У лайтов на евру, например, спрэд меньше, чем в альпари.


тестирую сейчас на 184 билде МТ4 размещенном на Liteforex картина та-же, мне кажется Метаквотевцы что-то замутили с компилятором, в более поздних релизах и многие советники перестали работать.
скоро все ДЦ закроют вход терминалам младше 180 релиза и пипец, :) может кто-нибудь из разработчиков подскажет какие нужно внести изменения в код советников, или каким-то образом доработать модуль что-бы они адекватно работали и в более поздних релизах.
за ранее благодарю. :)
Forex Trader
114280
Forex Trader  
В более поздних билдах меньше ошибок, в т.ч. и в тестере.
Возможно, нынешние тесты показывают истинную картину - советник сливает.
MetaQuotes Software Corp.
Модератор
185208
MetaQuotes Software Corp.  
Pavel VL, почитайте, пожалуйста, раздел сайта "Новости" - там явно описаны все исправления, внесенные в каждом билде. Уверен, что вопросы "где тестировать?" сразу отпадут.
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий