Lendo um Símbolo novo e Fazendo Backtest

 

Bom dia a Todos,

Gostaria de saber se tem como fazer Backtest de um ativo criado. Explicando melhor, eu peguei os dados reais no tick a tick e tb nos candles de 5 minutos... consigo criar um simbolo novo e carregar esses dados dentro do MT5, porém quanto estou tentando fazer um Backtest utilizando esse mesmo ativo criado, ele não está fazendo... eu preciso fazer alguma coisa ou o MT5 não deixa fazer Backtest de um símbolo criado?

 
Rafael Sekiguchi:

Bom dia a Todos,

Gostaria de saber se tem como fazer Backtest de um ativo criado. Explicando melhor, eu peguei os dados reais no tick a tick e tb nos candles de 5 minutos... consigo criar um simbolo novo e carregar esses dados dentro do MT5, porém quanto estou tentando fazer um Backtest utilizando esse mesmo ativo criado, ele não está fazendo... eu preciso fazer alguma coisa ou o MT5 não deixa fazer Backtest de um símbolo criado?

Eu fiz isso com uma versao de bova11 e da petr4 que queria ver ela sem os ajustes e nao lembro de ter problema, eu tive um na hora da carregar que tava ficando desparelho o csv. Sera que nao pode ser algum problema com a carga sua?

(os testes que fiz nos dois foi so no modelo OHLC de 1 minuto)

 
Ricardo Rodrigues Lucca #:
Eu fiz isso com uma versao de bova11 e da petr4 que queria ver ela sem os ajustes e nao lembro de ter problema, eu tive um na hora da carregar que tava ficando desparelho o csv. Sera que nao pode ser algum problema com a carga sua?

(os testes que fiz nos dois foi so no modelo OHLC de 1 minuto)

Então Ricardo, eu conferi a minha base de dados e está correto... eu crio o simbolo para poder Importar os ticks. Ele importa tudo certinho e eu consigo carregar na janela principal. Até ai tudo vem... consigo analisar com indicadores e tal, mas eu queria testar com uma EA, mas quando tento chamar, ele consegue executar, como se não tivesse histórico. Essa é a mensagem que aparece.


Arquivos anexados:
mql5.png  18 kb
 
Rafael Sekiguchi #:

Então Ricardo, eu conferi a minha base de dados e está correto... eu crio o simbolo para poder Importar os ticks. Ele importa tudo certinho e eu consigo carregar na janela principal. Até ai tudo vem... consigo analisar com indicadores e tal, mas eu queria testar com uma EA, mas quando tento chamar, ele consegue executar, como se não tivesse histórico. Essa é a mensagem que aparece.


Testa com uma data que nao seja o dia atual por favor.
 
Ricardo Rodrigues Lucca #:
Testa com uma data que nao seja o dia atual por favor.

Mas não é data atual... essa data ai é de 01/02/2023

 
Rafael Sekiguchi #:

Mas não é data atual... essa data ai é de 01/02/2023

Ah sim, eu tava com a fonte pequena foi mal.
 
Se alguém tiver alguma dica... como por exemplo... se for método de exportar os dados !!!
 
Rafael Sekiguchi #:
Se alguém tiver alguma dica... como por exemplo... se for método de exportar os dados !!!
Provavelmente é seu arquivo de importação. Mas não sei dizer aqui funciona, ti passar um link no privado.
 
Rafael Sekiguchi #:
Se alguém tiver alguma dica... como por exemplo... se for método de exportar os dados !!!

Rafael,

não custa perguntar.  No BT você está usando a MOEDA CORRETA ( B3 -> BRL )?

Razão: