Cannot adjust strategy tester spread anymore

lAspenwall
83
lAspenwall  
Hey

So iv been back testing an EA a lot lately. Watching different parameters play out. 

I like to play with spreads too. I average .5pips on account but like to test all the way up to 3.0 pips ( so 5 - 30 on tester) 

As of yesterday. I cannot adjust the spread. 
Well I can. But it does not test different. 
Before going from 5 to 6 could change total profit a big % over 2000 trades. Now I can set to 100 and it still tests as if it was around 5 or so. 

The report says the spread I choose. But the math is false. My trades stops are always under 10. I would be stopped out instantly with a 10.0 pip spread like it used to just a couple days ago. 

Anyone have similar problem before?
I have switched EA. restarted mt4. Changed pairs. No difference. 
Frustrating I have been making a lot of progress and now I am stuck
Alain Verleyen
42266
Alain Verleyen  
lAspenwall:
Hey

So iv been back testing an EA a lot lately. Watching different parameters play out. 

I like to play with spreads too. I average .5pips on account but like to test all the way up to 3.0 pips ( so 5 - 30 on tester) 

As of yesterday. I cannot adjust the spread. 
Well I can. But it does not test different. 
Before going from 5 to 6 could change total profit a big % over 2000 trades. Now I can set to 100 and it still tests as if it was around 5 or so. 

The report says the spread I choose. But the math is false. My trades stops are always under 10. I would be stopped out instantly with a 10.0 pip spread like it used to just a couple days ago. 

Anyone have similar problem before?
I have switched EA. restarted mt4. Changed pairs. No difference. 
Frustrating I have been making a lot of progress and now I am stuck
Which platform ? Which build ?
lAspenwall
83
lAspenwall  
Alain Verleyen:
Which platform ? Which build ?

my bad,

 

MT4 FXCM

Build 940

 Only changes I have done to my MT4 i can think of was I have started using this indicator <link removed by moderator> only a couple days ago.

 

 edit. my fault for posting link. The link was to a mt4 indicator that recorded and charts a histogram of average/high/low spreads.

 

Figured not a bad idea to watch spreads throughout day to help test to real spreads. Just not sure how it would affect strategy tester. 

Indicator is not used on strategy tester of course. Just my same EA i am backtesting. The spread indicator  is running on a seperate live chart.

 

My Tallinex Demo tests like usual with same indicator.

Tallinex MT4 build 910 

 

 I have tested a little more. And its only not working on 'Every Tick' setting

The 'control points' and 'open prices only' works fine. Changing spread drastically affects results. 

Telestes
6
Telestes  
lAspenwall:

my bad,

 

MT4 FXCM

Build 940

 Only changes I have done to my MT4 i can think of was I have started using this indicator <link removed by moderator> only a couple days ago.

 

 edit. my fault for posting link. The link was to a mt4 indicator that recorded and charts a histogram of average/high/low spreads.

 

Figured not a bad idea to watch spreads throughout day to help test to real spreads. Just not sure how it would affect strategy tester. 

Indicator is not used on strategy tester of course. Just my same EA i am backtesting. The spread indicator  is running on a seperate live chart.

 

My Tallinex Demo tests like usual with same indicator.

Tallinex MT4 build 910 

 

 I have tested a little more. And its only not working on 'Every Tick' setting

The 'control points' and 'open prices only' works fine. Changing spread drastically affects results. 

Same here for me under MT4 build 950.

Using the 'Every Tick' model in strategy tester doesn't use the Spread set anymore.

Instead the Spread is now 0 by default.

To work around this annoying bug:

1) Switch the test model to 'Open prices'

2) Now select or input a new Spread.

3) Start and stop backtest.

4) Change the model back to 'Every Tick'.

If you now start the backtest you will have the new Spread set also in this model.

Let's hope for a bug fix soon! 

Stuart Browne
11202
Stuart Browne  
Telestes:


Let's hope for a bug fix soon! 

Please report it to the service desk. Cheers!
Tomas Hruby
3858
Tomas Hruby  
Guys, this bug is still there.

I am absolutely worried about it. How did you solve it? Iam starting MT4 via .ini file and spread is current. Its testet with current spread and after markets open I am getting unconsitent results.
Any idea?