How to change value in Trade Settings

 

I can't change value in Trade Settings (MT5 tester setting). Anyone else encountering this problem as well ?


Trade Settings

 
momocoong:

I can't change value in Trade Settings (MT5 tester setting). Anyone else encountering this problem as well ?


Why have you posted in the MT4 section??

I will move your topic to the EA section.

 
momocoong: I can't change value in Trade Settings (MT5 tester setting). Anyone else encountering this problem as well ?

Forum on trading, automated trading systems and testing trading strategies

Strategy Tester

Fernando Carreiro, 2022.11.15 13:35

It is somewhat counter-intuitive, but you have to first enable the "Use custom settings" ...


Then you will be able to change the fields in the "Margins" tab ...


 
Fernando Carreiro #:

Alright. Now I can change value in "Commission" and "Trading" tab.

But can't change value in Margins tab.  Anyone else encountering this problem as well ?



 
momocoong #: Alright. Now I can change value in "Commission" and "Trading" tab.But can't change value in Margins tab.  Anyone else encountering this problem as well ?

A bug that has been reported before, but MetaQuotes has not fixed it.

Forum on trading, automated trading systems and testing trading strategies

MT5 Strategy Tester - "Margin call level" and "Stop out level" not changing

fizzix, 2021.08.04 12:17

I'm attempting to run a strategy test on one of my EAs. I'm emulating comission and a few other basic settings via the Delays and Slippage settings to ensure I'm testing with near-live trading conditions.


Although my issue here is with the "Margins" tab in the "Trade Settings" window after clicking on the small button next to the "Delays" item in the Strategy Tester. My "Margin call level" and "Stop out level" are stuck on 100 and 50 respectfully. Even if I try and change them to 50 and 30 and hit OK, they always revert back to 100 and 50. I've attempted many other combinations of numbers, yet no luck.


Why is this? These settings are crucial for me to test properly. I've attempted closing MT5 and restarting my computer with no avil.

 
This problem has been solved yet ?
Reason: