Optimization Forward Results Importing Cache Errors in MT5 Terminal

 

Does anyone know how to force MT5 terminal to NOT delete optimization cache files older than 30days? I want to be able to load older cache files into the terminal for analysis of forward results and I cannot find how to stop this deletion of cache files. 


The only option I'm aware of that the terminal will not delete them after 30days if the cache file has previously been accessed.  However there are several issues with importing optimization cache data in to mt5 and then having have multiple cache files in the folder.

Firstly, when importing a optimization cache it will often fail to load the forward results.  So you can import the cache file, and only the Optimization results tab shows...the forward results tab is not there. 

And then when it does load the forward results often it will often load the incorrect forward results cache...how it can do this I have no idea...but it does.

The ONLY reliable way I have found to load an optimization cache with the correct forward results is to close the terminal, manually delete ALL files in the tester/cache directory and then copy/paste the optimization cache files you have saved previously from an optimization/export into the tester/cache directory and restart the terminal.

This is the only way I have found to ensure the correct cache files are loaded and that the forward test tab shows up.  Delete everything apart from the cache files you want to load.

I have tried to resolve this issue  using a fresh new terminals, and most recent update, and then import then restart, close and manually import...nothing works consistently apart from the above method.

The issue I now face is that MT5 deletes cache files older than 30days if its not previously accessed , to save space.  It must somehow flag the cache file as being previously opened and this bypasses the auto delete function. 

This auto delete causes an issue as to get the correct cache to load, I must clear the cache then manually copy/paste cache files into the folder and so once I restart the terminal it see that there are cache files older than 30days and delates them.

This means I cannot load cache files older than 30days to review and analyses as the terminal automatically deletes them.

can anyone help override this auto delete function? 

 

I have deleted your new topic as it seems to be the same subject matter as this one.

Do not duplicate topics.

Keep your discussion concerning your issue here.

 
is any super users able to give me an answer on this important issue ?
 

I'm having almost the same issues.

Once I import the old .opt optimization files, why doesn't Strategy Tester run them?


Is there a way to let them work again? Please help.

I have more than 1.000 old tests and I have to open them.


IMPORTANT NOTE:  Even if I had opened and used the old caches( .opt files), They are all deleted after 30 days automatically.

But here: https://www.metatrader5.com/en/terminal/help/algotrading/strategy_optimization#cache

It says : 

  • For optimize disk space usage, cache files are automatically deleted if they are not accessed within 30 days.

But as I said, I used many of them before 30 days but they are all gone!

Strategy Optimization - Algorithmic Trading, Trading Robots - MetaTrader 5 Help
Strategy Optimization - Algorithmic Trading, Trading Robots - MetaTrader 5 Help
  • www.metatrader5.com
The Strategy Tester allows you to test and optimize trading strategies ( Expert Advisors ) before using them for live trading. During testing, an...
Reason: