Download MetaTrader 5

Multicore/thread tester

To add comments, please log in or register
Order the development and track its status via your mobile phone.
Jeremy Roach
2457
Jeremy Roach 2015.03.24 03:53 

Hi all,

 Just wondering if there is an option somewhere that affects the use of multicore/thread CPUs in the MT5 tester?

I ask, as previously - up until yesterday my MT5 tester would stream through testing using all 8 cores, now it only does 1, then it might start using another core 3/4 through the whole test.

Does anyone know why this is going on and how to fix it?

My PC isn't doing much else other then testing.

Thanks 

jcollin.be
5
jcollin.be 2015.03.28 18:22  

Hi,

 I also have an issue with the tester on my 8 core I7.

The Tester uses all the cores but it is very very slow and even much slower than on another machine 4 cores I5.
For the same EA, it takes 6 minutes to perform 100 passes on the 8 core and only 22 seconds on the 4 core!!! And I clean the cache before each execution.

 Is there something wrong with MT5 when run on 8 core machines?

Of course, solutions are welcome :)

 Ah and I cannot use the cloud or the remote agent as I use external dlls.

 Thank you for your answers? 

Lars Rompe
614
Lars Rompe 2016.03.22 16:56  

Hi both,

 

1. first of all you may want to check if all cores are really active

Therefore enter the msconfig (I assume you know how that works - keep in mind to do that changes as ADMIN) and click:

    • Win-R - msconfig
    • Boot tab 
    • Advanced Options
    • Number of Processors

You may check the processors that are actively used by Windows
msconfig cores

 

 2. You may limit the cores used by certain programs

Enter:

  • Press Ctrl+Alt+Del 
  • Start Task Manager 
  • Processes Tab 
  • right click desired program 
  • Set Affinity  
Adjust according to your expectations (e.g. to free some CPU for your regular work ;-))

Processes to cores association


3. Disable Hyperthreading Cores

In case you own Intel dual/multi-core - it has 4 "logical" cores and a quad-core has 8 "logical" cores which is meant by "Hyperthreading". 

I think Hyperthreading isn't working as it should in the marketing material - CPU is getting hot and the real benchmark results in the performance section of Windows do not improve.

Also subjective feeling is that it does not work.

You can disable these logical cores in the mainboard BIOS. 

You will have to press F2 during boot (or F8 or F12 in certain models) to enter BIOS. 

The option you have to look for is named "Hyperthreading [Enabled/Disabled]".


Enjoy!
Stephen Njuki
5179
Stephen Njuki 2016.03.24 08:43  
Also make sure you have enough virtual memory per core/thread. Typically 2GB per thread is a minimum.
Ruy Bentes
143
Ruy Bentes 2016.06.26 14:11  
What a great explanation, Lars! Thanks!!
To add comments, please log in or register