OrderCheck() failed: AutoTrading disabled by client (10027)

 

Hey guys,

I have an interesting problem. I'm using Interserver VPS for multiple accounts. Same bot, same code, same setup.

But on one of the servers I always get this line in the Experts tab:

2022.01.04 11:40:28.542    Experts    automated trading is enabled

2022.01.04 21:00:00.076    Algo Solutions Ultimate (EURNZD,H1)    OrderCheck() failed: AutoTrading disabled by client (10027)

That is weird because no one turned off Automated trading.

The MT5 is always open on the VPS and the sleep/hybernate option is turned off.

 
Check your MT4/5 >> Tools >> Options >> Expert Advisors tab settings.
 
Eleni Anna Branou #:
Check your MT4/5 >> Tools >> Options >> Expert Advisors tab settings.
Its the same as in the working one, only Automated Trading and DLL are checked
 
Eleni Anna Branou #:
Check your MT4/5 >> Tools >> Options >> Expert Advisors tab settings.
If i turned it off this would show in the Expert tab


2022.01.05 12:56:44.161    Experts    automated trading is disabled


But there isn't any activity between enabling auto trading and getting the error that it's turned off.

 
I recently had this error. Open the Expert Advisor Settings on the particular chart window, in the "Common" Tab, "Allow Algo Trading" must be checked. I think this feature allow individual Experts Advisors to be turned on or off on each chart, which has a precedence on the Allow Algo Trading icon in the Standard Bar.
 
Joseph Faithful Myers #:
I recently had this error. Open the Expert Advisor Settings on the particular chart window, in the "Common" Tab, "Allow Algo Trading" must be checked. I think this feature allow individual Experts Advisors to be turned on or off on each chart, which has a precedence on the Allow Algo Trading icon in the Standard Bar.

thanks

 
I'm having the same error, I recently got an account from [redacted] and I can't place any orders with the trading panel, tried both methods, in the tool options and also in the Common Tab and still having the same issue, please help.
Reason: