Signal not reading currency pairs

Sean Arrowsmith
26
Sean Arrowsmith  

Hi, first post, so please be gentle :)

I have added a signal to MT4 (running on the MQL5 VPS), and I keep getting error "Signal - symbol GBPJPY has inconsistent trade mode".

I followed the instructions here: https://www.mql5.com/en/forum/301310

I have enabled all currency pairs (Symbols > Show)

When I look at the specification for GBPJPY.r (note the '.r'), trade is Full Access. However, when I look at GBPJPY (without '.r') trade is disabled. 

I have contacted my broker (Pepperstone) and they have said trade is enabled on my account, and they could not work out why the signal was not being processed properly. 


Is it a broker issue, or is it an issue with the signal?

The server log shows the signal to be enabled.

Server journal


What am I missing/doing wrong?

Thanks in advance

Sean

Please help with "symbol EURUSD has inconsistent trade mode" problem?
Please help with "symbol EURUSD has inconsistent trade mode" problem?
  • 2019.01.30
  • www.mql5.com
I trade with LMAX. MY mt4 is not copying trade from my signal provider. EURUSD symbol not mapping to EURUSD.lmx. Please help? 2019.01.30 09:34:31...
Juvenille Emperor Limited
Moderator
15393
Eleni Anna Branou  
Sean Arrowsmith:

Hi, first post, so please be gentle :)

I have added a signal to MT4 (running on the MQL5 VPS), and I keep getting error "Signal - symbol GBPJPY has inconsistent trade mode".

I followed the instructions here: https://www.mql5.com/en/forum/301310

I have enabled all currency pairs (Symbols > Show)

When I look at the specification for GBPJPY.r (note the '.r'), trade is Full Access. However, when I look at GBPJPY (without '.r') trade is disabled. 

I have contacted my broker (Pepperstone) and they have said trade is enabled on my account, and they could not work out why the signal was not being processed properly. 


Is it a broker issue, or is it an issue with the signal?

The server log shows the signal to be enabled.


What am I missing/doing wrong?

Thanks in advance

Sean

The signal you are copying is probably using the symbol GBPJPY and in your account that symbol is disabled.

If in your MT4/5 >> View >> Symbols, the symbol GBPJPY cannot be enabled you can only trade (from what you say) GBPJPY.r but this is not mapped correctly with the signal's GBPJPY so there is a problem there.

You either find a way with your broker to be able to trade the normal GBPJPY and not the one with the suffix .r or you use another broker.