MT4 - Freezing - windows 10 ethernet throttling?

To add comments, please log in or register
Geo Trading
Geo Trading  


Ive been searching & searching but i cant seem to find the solution.

During peak moments MT4 sometimes stops responding. Meaning i cant switch from oné to an other... but the EA is still running solid in the background & does its calculations & trades.

It also doesnt say in Task manager - Not responding... My expert isnt very consuming either.

My ram is never above 50%, my CPU never moves above 50% , my Disk usage is never above 5%... But my Ethernet is always switching (see gif)

So im thinking my windows 10 is throttling/limiting my bandwith and then when i see it switch up (gif) and wait a bit im again able to switch between MT4's. I also adjusted some options in MT4 (disable news, disable sound, Max bars in history & Max bars in chart lowered, Marketwatch Hide all )

I have this issue on my local system & i have this issue on my VPS as well (Windows server 2016) 

My setup Metatrader setup:

14 x MT4 , 2 pairs x4 timeframes (Per mt4), 112 charts in Total  (Expert advisor)

My systems:

I9-9900K - Gigabyte Z390 Aorus motherboard - 32 DDR4 Ram - Samsung SSD - Nvidia Quadro P620 (4screens) - Intel(R) Ethernet Connection (7) I219-V ( Its the standard ethernet card from my motherboard)

I7-8700k ... (more or less same setup)

Vps:  4xVcpu @ 4ghz - 12GbRam - SSD 60gig (windows server 2016)

Speedtest online :

Download: 190mbps

Upload: 180mbps

Im kinda stuck at this moment for a few weeks now, any help/tips would be appreciated.

William Roeder
William Roeder  

14 terminals? Sounds like a paging problem. I've had the same thing on my laptop - everything just stops, idle CPU, disk, network, no hard faults, according to resmon ( "%windir%\system32\perfmon.exe" /res).

  1. Change Tools → Options (control-O) → Charts → Max bars in chart to something reasonable like 1K.
  2. And/Or disable Superfetch: run (window-R) → cmd → services.msc.
To add comments, please log in or register