Cannot change data in Inputs (MT5)

To add comments, please log in or register
RON7N
61
RON7N  

Hello,

I cannot change data in the Inputs when I try to test any AE.  After the change, it goes back to defaults.

Can you advise what can be wrong?


Thanks

Vladimir Karputov
Moderator
150983
Vladimir Karputov  
RON7N :

Hello,

I cannot change data in the Inputs when I try to test any AE.  After the change, it goes back to defaults.

Can you advise what can be wrong?


Thanks

Do you have the same problem?

MT5 самостоятельно сбрасывает настройки в тестере после перехода на вкладку "Настройки"


Here is the problem in the screenshots:

1) First, we set any settings for testing:


Go to the Settings page:


Go back and see that all the checkboxes and settings disappeared by themselves:

Jan
47
Jan  

Hello,

I have the same issue too.  I use  MT5 Version 5.00 build 2007 25 feb 2019. I installed the metatrader on a location where I can control the ownership of the files in a maximum way. I start the workstation in /portable mode to also have the Data folder in the same location.  For testing I use the ExpertMACD EA

Any ideas are more then wlecome. I am more then prepared to install an older version of the metatrader5 software if somebody is willing to share a setup file. For now I installed Metatrader version 4 Build 1170 on the same drive and with /portable option. In this metatrader changing inputs works.

Jan

Michael Williams
24
Michael Williams  
I have the same problem
Michael Williams
24
Michael Williams  
Has anyone created a service ticket for this problem?  
RON7N
61
RON7N  

Hello Vladimir, everybody,

Thank you for your update and I'm sorry for my late reply. Yes, I have exactly the same problem that you have described with screenshots.

Please tell me, is there any solution about it?


Thanks,

Michael

Michael Williams
24
Michael Williams  
RON7N:

Hello Vladimir, everybody,

Thank you for your update and I'm sorry for my late reply. Yes, I have exactly the same problem that you have described with screenshots.

Please tell me, is there any solution about it?


Thanks,

Michael

RON7N are you running Window 7 ?  I am, just wondering if it's an issue isolated to Windows 7.  So I was fortunate I had older versions of MT5 on my computer.  Right now I'm running an older version, and clicking no for MT5 automatic updates.  I hope they resolve this issue soon.

Mark Us
523
Mark Us  
I have the same problem with Windows Server 2016. On my other 2016 Server the same MT5 built works with no problems...
Mark Us
523
Mark Us  

I think I have a solution.

here I have downloaded the old MT5 builds  ....
https://drive.google.com/drive/folders/1YSUVehcElTpLxCLPMsdlDfFu4Y61yrcc

Then I took the files from the Build 1971 and overwrote the files in the MT5 program folder. MT5 must be closed. After the restart you will have the MT5 Build 1971 from January 2019.

If I now edit the settings, they will NOT change after clicking the TAPs. :) Backtest I have not done yet. First posted here;). At the next start, however, there is again an auto update of the MT5. Let's see how this can be suppressed - or keep repeating, or not close MT5 :). Server is always on with me anyway.


This should be the error in the last builds & hopefully be fixed soon ....

lippmaje
371
lippmaje  
Mark Us:

If I now edit the settings, they will NOT change after clicking the TAPs. :) Backtest I have not done yet. First posted here;). At the next start, however, there is again an auto update of the MT5. Let's see how this can be suppressed - or keep repeating, or not close MT5 :). Server is always on with me anyway.

Preventing MT from updating is quite easy. You just need to withdraw Read permission for Administrator on the downloaded files. Do this after download completed and before restarting MT.

Steps:

  • open folder C:\Users\<youruser>\AppData\Roaming\MetaQuotes\Terminal
  • the download is contained in a directory named like D8275896C3BD1B4D443353853F139F66, open properties of it
  • flip to security settings, push Modify... button, a dialog with users and rights will open
  • select Administrator in the list, below a column with checkboxes is shown
  • check Read in the column to withdraw permissions, close all with ok
  • next time MT is started it will not be able to apply its update, and also it won't download more of them
  • if you want to receive updates again, revert the change on that folder
To add comments, please log in or register