Download older MT4 versions?

To add comments, please log in or register
Cake
49
Cake  

Hi all,

Due to ESMA and FCA restrictions I was forced to change brokers to keep my 500:1 leverage. I thought I would look at Markets (comments not welcome on them please). However all my machines run Vista and since there is no support anymore they don't supply an older version. Does anyone have one please?

The ones I use were supplied from X and Y and will not allow me to find any other servers.

If there are recommendations to other brokers feel free to comment here. Thanks.

whroeder1
17944
whroeder1  
  1. Can't use old versions.
    The MetaTrader platforms will no longer support Windows XP, Windows 2003 and Windows Vista after 01 October 2017.
               Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017 - General - MQL5 programming forum MetaQuotes Software Corp. 2017.06.01 08:02

  2. When you registered you agreed to Metaquotes' rules, including: Coarse language is forbidden. advertising messages, spamming and flooding are forbidden. Broker discussions are forbidden here.
              General rules and best pratices of the Forum. - Demo Account - General - MQL5 programming forum
Cake
49
Cake  
ah ok.
kypa
976
kypa  

Are you sure you can't find servers from File/Open Account (not File/Log In)?

Alternatively you can copy terminal.exe into another folder and run it, it should download all the other files and run like a copy downloaded from MetaQuotes in the good old days.

lalana bules
14
lalana bules  
kypa:

Are you sure you can't find servers from File/Open Account (not File/Log In)?

Alternatively you can copy terminal.exe into another folder and run it, it should download all the other files and run like a copy downloaded from MetaQuotes in the good old days.

Cake
49
Cake  
kypa:

Are you sure you can't find servers from File/Open Account (not File/Log In)?

Alternatively you can copy terminal.exe into another folder and run it, it should download all the other files and run like a copy downloaded from MetaQuotes in the good old days.

No doesn't work. tried the X version and the Y version. They just see themselves no other brokers.

ok that suggestion sounds promising. Can you walk me through how to do that? I'll use the X one as I stopped using that one. I see the Terminal file in the main folder once I open it. where should I copy it to?


update-

I realised what you meant. I created a new folder and dropped it in. Opened it and program opens up. did a broker search but it will not find any!!?? It says upgrade to internet explorer 8 or higher now!

kypa
976
kypa  

You should probably upgrade IE, either from update manager or MSFT site.

This might be the reason it's not showing other brokers by the way.
Cake
49
Cake  
kypa:

You should probably upgrade IE, either from update manager or MSFT site.

This might be the reason it's not showing other brokers by the way.
I actually never use it. I use Firefox. i'll try it and see. If I could just find an older version of X Markets that would solve all this nonsense.
Graham from Brisbane
64
Graham from Brisbane  
Why not upgrade your machine to Windows 10. Doesn't cost very much, and there are heaps of benefits in addition to MT4 working properly :)
kypa
976
kypa  

Firefox is the best browser ever made. It is MetaTrader that is using IE, part of it actually. You can install IE and disable it in Programs/Windows Components.

It might be an issue with firewall or antivirus, you may check those settings as well.

Windows 10 is awful, especially on older machines. It does whatever it wants in the least desirable moments and it will grind your HDD/SSD to death much sooner than you'd expect. It's probably worse than Vista itself. Windows 8.1 is more viable option, but also not so much to be worth paying for. If license is an issue Linux is the best alternative.

whroeder1
17944
whroeder1  
What part of "Can't use old versions." was unclear? You should have already been on Win 8 or higher with an updated IE/edge. Stop wasting everyone's time.
The MetaTrader platforms will no longer support Windows XP, Windows 2003 and Windows Vista after 01 October 2017.
           Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017 - General - MQL5 programming forum MetaQuotes Software Corp. 2017.06.01 08:02
12
To add comments, please log in or register