Download MetaTrader 5
To add comments, please log in or register
Do you have Mac OS? Find out how to install MetaTrader on it!
Aashay Tiwari
140
Aashay Tiwari 2014.03.11 05:17 

Hi,

I am using the MT4 version 4.0.0.610 (build 610??).

But every time i add a new indicator to the folder i cant see it in the navigator pane of my terminal. I copy it to "program files>metatrader4>experts>indicators"

This is the same folder where all the custom indicators are. When i manually compile i in metaeditor i get the "EX4 write error".

What am i doing wrong? Is it possible to revert back to an older version of MT4?

Please help. Thank you.

Keith Watford
Moderator
7887
Keith Watford 2014.03.11 05:57  
"program files>metatrader4>MQL4>indicators"
Alain Verleyen
Moderator
28535
Alain Verleyen 2014.03.11 07:56  
azzkikr:

Hi,

I am using the MT4 version 4.0.0.610 (build 610??).

But every time i add a new indicator to the folder i cant see it in the navigator pane of my terminal. I copy it to "program files>metatrader4>experts>indicators"

This is the same folder where all the custom indicators are. When i manually compile i in metaeditor i get the "EX4 write error".

What am i doing wrong? Is it possible to revert back to an older version of MT4?

Please help. Thank you.

Data Structure in MetaTrader 4 Build 600 and Higher
Aashay Tiwari
140
Aashay Tiwari 2014.03.15 11:32  

Thank you. That helped :)
Aashay Tiwari
140
Aashay Tiwari 2014.03.15 11:35  
GumRai:
"program files>metatrader4>MQL4>indicators"


The new version requires you to copy indicators/experts to a new "terminal data folder" which is not in the program files.

Thank you very much for the help though.

Keith Watford
Moderator
7887
Keith Watford 2014.03.15 12:48  
azzkikr:

Hi,

I am using the MT4 version 4.0.0.610 (build 610??).

But every time i add a new indicator to the folder i cant see it in the navigator pane of my terminal. I copy it to "program files>metatrader4>experts>indicators"

This is the same folder where all the custom indicators are. When i manually compile i in metaeditor i get the "EX4 write error".

What am i doing wrong? Is it possible to revert back to an older version of MT4?

Please help. Thank you.


GumRai:
"program files>metatrader4>MQL4>indicators"

azzkikr:


The new version requires you to copy indicators/experts to a new "terminal data folder" which is not in the program files.

Thank you very much for the help though.


Really?

Have you moved your MT4 platform files since your first post?

Now that you know where the indicator files are stored, please open that location, copy the file path in the address window and post it here

65002492
4
65002492 2014.06.27 21:09  

Hey people, I am also relatively new to coding on the mt4 platform and im very interested in using custom indicators to take my trading to the next level. I'm using ECN's mt4 version 5.0.0.910 which has been giving me quite a headache when trying to load indicators, 2 out of 30 have complied the others which successfully compile fail to generate ex4 files while others give me a "ex4 write error" message. For example the dailylines indicator had no error but didnt generate its ex4 file on compilation so i tried using the previous version of of mt4 509 which generated an ex4 file which failed to load on my newer version terminal once i copied it to corresponding appdata  indicator folder. 


PLIZ SOMEONE HELP!!

Files:
whroeder1
13600
whroeder1 2014.06.28 12:34  
Ndotombaya: "ex4 write error" message.
You must have a bad installation if it can't write to the disk (or your disk is full.) Backup your files, Uninstall, delete the data directory. Reinstall (don't use as Admin) retry.
65002492
4
65002492 2014.06.28 16:00  
WHRoeder:
Ndotombaya: "ex4 write error" message.
You must have a bad installation if it can't write to the disk (or your disk is full.) Backup your files, Uninstall, delete the data directory. Reinstall (don't use as Admin) retry.


Thanks a bunch WHRoeder it worked, weekstart will be a different experience for me
/
To add comments, please log in or register