Download MetaTrader 5

Symbol GBPCAD is not available for strategy tester

To add comments, please log in or register
daveh551
34
daveh551  

Please forgive me, I'm relatively new to using the Strategy tester.

I'm trying to test an EA I've written to implement a strategy on GBPCAD.  But when I click in the "Symbol" box on the Strategy Tester Settings, I get a drop down list of Symbols, and GBPCAD is not there.  I see no options for adding it. GBPCAD is showing up in Market Watch, and I have a GBPCAD chart open.

Can anyone help me?

 Thanks.

Dave 

Simon Gniadkowski
Moderator
18078
Simon Gniadkowski  
daveh551:

Please forgive me, I'm relatively new to using the Strategy tester.

I'm trying to test an EA I've written to implement a strategy on GBPCAD.  But when I click in the "Symbol" box on the Strategy Tester Settings, I get a drop down list of Symbols, and GBPCAD is not there.  I see no options for adding it. GBPCAD is showing up in Market Watch, and I have a GBPCAD chart open.

In the Market Watch right click and then click Show All,  if that doesn't bring up GBPCAD then your Broker does not offer it.
daveh551
34
daveh551  
RaptorUK:
In the Market Watch right click and then click Show All,  if that doesn't bring up GBPCAD then your Broker does not offer it.


Thanks for your reply, Raptor, but I do have GBPCAD showing in the MarketWatch window. In fact, I have a GBPCAD chart open. However, it is NOT showing in the list of selections to run the strategy tester against, when I click "Symbol" in the Strategy Tester settings.
Simon Gniadkowski
Moderator
18078
Simon Gniadkowski  
daveh551:

Thanks for your reply, Raptor, but I do have GBPCAD showing in the MarketWatch window. In fact, I have a GBPCAD chart open. However, it is NOT showing in the list of selections to run the strategy tester against, when I click "Symbol" in the Strategy Tester settings.

Did you try scrolling the list up and down ?

 

Steve
14
Steve  
Simon Gniadkowski:

Did you try scrolling the list up and down ?

 

I have exactly the same problem...and your solution does not work, sorry to say. There is no scroll bar on the right.

If there were, I think it's fair to say this question would not have been posted.

Steve
14
Steve  
daveh551:

Thanks for your reply, Raptor, but I do have GBPCAD showing in the MarketWatch window. In fact, I have a GBPCAD chart open. However, it is NOT showing in the list of selections to run the strategy tester against, when I click "Symbol" in the Strategy Tester settings.

Dave, did you ever get the answer?

I have exactly the same issue :(

Thx.

Alain Verleyen
Moderator
36428
Alain Verleyen  
Steve:

Dave, did you ever get the answer?

I have exactly the same issue :(

Thx.

If the symbol appears in Market Watch but not in Strategy Tester list, then restart MT4.
Keith Watford
Moderator
12127
Keith Watford  

Many years ago I had this problem a few times.

Attach the EA to a chart of the symbol that you want to trade (disable autotrading)

Right click on the chart, click on Expert advisor and then Strategy Tester.

It should open the Strategy tester with the symbol.

Alain Verleyen
Moderator
36428
Alain Verleyen  
Keith Watford:

Many years ago I had this problem a few times.

Attach the EA to a chart of the symbol that you want to trade (disable autotrading)

Right click on the chart, click on Expert advisor and then Strategy Tester.

It should open the Strategy tester with the symbol.

Faster to restart MT4
To add comments, please log in or register