MT5: no connection since one week, firewall question

Einloggen oder registrieren, um einen Kommentar zu schreiben
Alex
123
Alex  

Hi,

I have installed MT5 and it worked since months without problems. But suddenly, since one week or so, I always get the "no connection" error message. I did not really change anything in my network, but an update could interfere the connection. I 'm behind hardware firewall appliance and traffic over port 443 is allowed, means I can surf on https-sites with my browser without problems.
But MT5 stopped connecting. For testing I added a firewall rule to allow any traffic from inside my network to outside world => MT5 is connecting again! Google tells me that allowing port 443 should be sufficient, but it seems not.

Were there any changes about MT5 connection? Which ports do I have to allow to get MT5 connecting again?

Thank you,
Alex


Hallo,

Ich habe eine MT5 Installation, die seit Monaten funktioniert. Aber seit ungefähr einer Woche habe ich "no connection" Errors. Ich habe eigentlich nichts an meinem Netzwerk verändert, aber vielleicht hat ein Update etwas verändert. Ich bin hinter einer Hardware Firewall Appliance und Port 443 ist erlaubt,  mit einem Browser kann ich problemlos auf https-Seiten surfen.
Zum Test habe ich eine Firewall Regel erstellt die sämtlichen Traffic auf jedem Port zulässt und siehe da => MT5 verbindet sich wieder! Google sagt, dass wenn Traffic über Port 443 erlaubt ist, der MT5 laufen sollte, was er aber nicht tut.

Hat es Änderungen bei der Verbindung von MT5 gegeben? Welchen Port muss ich öffnen, damit MT5 wieder normal läuft?

Danke und schöne Grüße,
Alex

Carl Schreiber
Moderator
9862
Carl Schreiber  
Vielleicht war das das Windows 10 update, das wohl einiges zurückgesetzt hat?
Alex
123
Alex  
Carl Schreiber:
Vielleicht war das das Windows 10 update, das wohl einiges zurückgesetzt hat?

lief schon unter Win10. Außerdem ist ja wirklich die Firewall auf der HW Appliance der Knackpunkt. Weiß jemand definitiv, welche Ports/Protokolle der MT5 benötigt?
Christian
3172
Christian  
Alex:

lief schon unter Win10. Außerdem ist ja wirklich die Firewall auf der HW Appliance der Knackpunkt. Weiß jemand definitiv, welche Ports/Protokolle der MT5 benötigt?


Mt4 und 5 nutzen nur 443 .

zu mindestens sehe ich in den Verbindungen nichts anderes

Alex
123
Alex  
Christian:


Mt4 und 5 nutzen nur 443 .

zu mindestens sehe ich in den Verbindungen nichts anderes


Ok danke. Weißt du zufällig noch welches Protokoll? UDP, TCP?
Christian
3172
Christian  
Alex:

Ok danke. Weißt du zufällig noch welches Protokoll? UDP, TCP?

Muss Tcp sein
Christian
3172
Christian  

Eigentlich sollte 443 ja immer funktionieren weil darüber ja HTTPS geht.

Und das würdest du ja schnell merken. 

Alex
123
Alex  
Christian:

Eigentlich sollte 443 ja immer funktionieren weil darüber ja HTTPS geht.

Und das würdest du ja schnell merken. 


Ja, das ist es ja. SSL geht, zumindest im Browser beim Surfen. Mal sehen, eventuell blockt die Appliance (Sophos UTM9) den Traffic wegen eines Patterns - zum heulen. Ich habe nämlich an den FW Regeln nichts verändert.
Christian
3172
Christian  
Alex:

Ja, das ist es ja. SSL geht, zumindest im Browser beim Surfen. Mal sehen, eventuell blockt die Appliance (Sophos UTM9) den Traffic wegen eines Patterns - zum heulen. Ich habe nämlich an den FW Regeln nichts verändert.

Wenn du dich mit dem Handy in deinen Broker einloggen kannst bleibt ja nur noch dein Rechner. Ist da ne FW drauf die die *.exe blockt ?
Alex
123
Alex  
Christian:

Wenn du dich mit dem Handy in deinen Broker einloggen kannst bleibt ja nur noch dein Rechner. Ist da ne FW drauf die die *.exe blockt ?


Geht alles, nur der MT5 nicht (mehr). Ich habe dieses Verhalten sowohl auf nem Win10 Domänenrechner als auch auf einem Win7 Nicht-Domänenrechner. Beide haben funktioniert. Die FW-Appliance erlaubt standardmäßig schon immer von innen nach außen nur 80,443,25,110,22, ... so Standard Ports eben und da funktionierte es bisher. Nun war ich im Urlaub, an der Appliance hat sonst niemand Zugriff und nun gehts plötzlich nicht mehr.

 Sobald ich auf der Appliance eine Test-FW-Regel erstelle "_alles_ darf von innen nach außen egal welcher Port oder Protokoll" dann ist sofort die Verbindung da. Daher muss es an der Appliance liegen. Und wenn sich beim MT5 nicht der Kommunikationsport von 443/TCP geändert hat, kann ich mir nur noch vorstellen, dass ein Pattern dran schuld ist (mit diesen Patterns wird der Datenstrom selbst auf böse Sachen untersucht, und da gibt es eben auch automatische Pattern-Updates, welche ohne mein Zutun installiert werden könnten)

Christian
3172
Christian  

Wenn du dich mit dem Handy über Wlan einloggen kannst beim Broker mit MT5 oder MT4 kann es eigentlich kein drop über ein Pattern sein.Das Protokoll ist ja das selbe . Ob Android oder Windows.


Das wird an deinem Windows Rechner liegen zu 99% :-) kleine Hintertür brauch ich 

12
Einloggen oder registrieren, um einen Kommentar zu schreiben