Скачать MetaTrader 5

ФОРТС Компилятор 1178 не совместим с предыдущими версиями терминала?

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Знаете ли вы, что MQL5 является объектно-ориентированным языком?
Mikhail Filimonov
5931
Mikhail Filimonov 2015.10.15 18:02 

Уважаемые разработчики!

Скомпилировал советника на билде 1178 (ошибок не было), а запустил на 1159 результат:

2015.10.15 18:53:12.665 Forts_trader (AUDU-12.15,H1)    EX5 loading failed
MetaQuotes
Админ
24947
Renat Fatkhullin 2015.10.15 18:08  
Михаил:

Уважаемые разработчики!

Скомпилировал советника на билде 1178 (ошибок не было), а запустил на 1159 результат:

Да, версия файлов изменилась, поэтому обратной совместимости нет.

Мало того, с 1178 билда по умолчанию включен новый оптимизирующий компилятор, который генерирует гораздо более быстрый код.

Используйте последний билд даже при подключении к старым серверам. Терминалы поддерживают очень глубокую совместимость со старыми серверами.

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий