Скачать MetaTrader 5
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Проблемы с кодом? Загляни в документацию!
MetaQuotes Software Corp.
Модератор
177409
MetaQuotes Software Corp. 2009.10.07 05:20 

WPR_JMA:

В основе лежит инвертированная версия WPR (от MetaQuotes). Добавлено JMA-сглаживание (Nikolay Kositsin). Выведены значения WPR не только по Close, но и по остальным ценовым уровням (High, Low, Open). Пунктиром выведены разности между WPR (HLOC).

Author: Henry_White

MQL4 Comments
16309
MQL4 Comments 2009.10.07 17:19  
Henry_White:

Куда-то делась картинка... Добавляю.

Ваш индикатор не устанавливается. Опишите, как его установить

Henry_White
256
Henry_White 2009.10.07 19:40  

bar писал(а):

Ваш индикатор не устанавливается. Опишите, как его установить

 JJMASeries.mqh скопируйте в каталог include. Если не получилось, тогда подробнее опишите, что вы делаете и что выдает МТ4 при компиляции.

MQL4 Comments
16309
MQL4 Comments 2009.10.07 20:31  
bar:
Henry_White:

Куда-то делась картинка... Добавляю.

Ваш индикатор не устанавливается. Опишите, как его установить

Выполнил всё как Вы написали:

WPR_JMA-HLOC.mq4 - закинул в индикаторы, а

JJMASeries.mqh - в include и всё попрежнему

MQL4 Comments
16309
MQL4 Comments 2009.10.08 10:56  
bar:
bar:
Henry_White:

Куда-то делась картинка... Добавляю.

Ваш индикатор не устанавливается. Опишите, как его установить

Выполнил всё как Вы написали:

WPR_JMA-HLOC.mq4 - закинул в индикаторы, а

JJMASeries.mqh - в include и всё попрежнему


В include должно быть ещё вот это- PriceSeries.mqh-я брал отсюда : https://www.mql5.com/ru/articles/download/1563


Henry_White
256
Henry_White 2009.10.09 08:37  

Igor.F.B писал(а):

В include должно быть ещё вот это- PriceSeries.mqh-я брал отсюда : https://www.mql5.com/ru/articles/download/1563

В этой библиотеке нет необходимости. К ней обращения нет в индикаторе.

MQL4 Comments
16309
MQL4 Comments 2009.10.09 11:22  
Henry_White:

Igor.F.B писал(а):

В include должно быть ещё вот это- PriceSeries.mqh-я брал отсюда : https://www.mql5.com/ru/articles/download/1563

В этой библиотеке нет необходимости. К ней обращения нет в индикаторе.


Henry_White:

Igor.F.B писал(а):

В include должно быть ещё вот это- PriceSeries.mqh-я брал отсюда : https://www.mql5.com/ru/articles/download/1563

В этой библиотеке нет необходимости. К ней обращения нет в индикаторе.



Как ни странно, но без этой библиотеки у меня выдало ошибку при компиляции с её упоминанием. Установил и всё скомпилировалось.

Henry_White
256
Henry_White 2009.10.11 08:02  
Igor.F.B писал(а):
Как ни странно, но без этой библиотеки у меня выдало ошибку при компиляции с её упоминанием. Установил и всё скомпилировалось.

  Мой косяк. Был лишний include c неиспользуемой библиотекой. Исправил.

Леонид
1782
Леонид 2011.01.06 00:40  
а нужно ?
/
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий