Download MetaTrader 5

mql5 EA on mt4 : can't find the compiled EA

To add comments, please log in or register
The entire MQL5.community history on a single page!
oscarik
16
oscarik 2016.07.22 08:53 

Hi,

I recently download and use mt4. I choose mt4 cause of automated trading, and my targeted broker use it.

Since I heard that mql5 works on mt4, I read mql5 book (ExpertAdvisorBook) and wrote one simple mlq5 EA in mt4. A that time, I mostly copy/paste example from book, my mql5 EA on mt4 is compiling well (just some warning, no errors).

My problem : My compiled EA doesn't appear : EA Explorer doesn't show it, Testing Strategy doesn't show it  too.

I tried to search on web this kind of problem, but without success. 

An idea ? I am wrong somewhere ?


Thanks for your answers.


Oscar.

Sergey Golubev
Moderator
93763
Sergey Golubev 2016.07.22 09:06  

As far as I know

  • mlq5 EAs for mt5
  • mlq4 EAs for mt4
oscarik
16
oscarik 2016.07.23 18:40  

This is the source where I found the information. But nevermind, I can develop in mql4 language too. Thanks for you answer.

https://docs.mql4.com/mql4changes

What's New in MQL4

Starting from build 600, MQL4 programming language has been completely revised reaching the level of MQL5 - now you can develop trading robots in MQL4/5 using the unified MetaEditor development environment, single style, libraries and debugging tools.

MQL4 is popular among automated system developers due to the ease of learning and a huge amount of code generated for many years of using MetaTrader 4 terminal. However, the language also has some drawbacks arising from its main advantage - a simple programming language does not allow development of complex systems and hinders porting of debugged libraries from high-level languages. Therefore, we decided to implement in it the maximum possible amount of MQL5 language functions and features fully preserving MQL4 functionality. In other words, all powerful MQL5 functions, including ООP and the native code compiler, will become available in MQL4.

To achieve this, we have developed a unified compiler that automatically supports both MQL4 and MQL5 languages. MetaEditor will also become a unified application both for MetaTrader 4 and MetaTrader 5 platforms. Thus, it will be possible to compile both MQL4 and MQL5 from any version. MQL5 Storage also becomes available for work.




Updated MQL4 - MQL4 Reference
Updated MQL4 - MQL4 Reference
  • docs.mql4.com
Updated MQL4 - MQL4 Reference
Jose Francisco Casado Fernandez
2407
Jose Francisco Casado Fernandez 2016.07.23 21:59  
Mql5 EAs don't work on MT4 and vice-versa. Compiler supports both languages, but it's a different thing. Commercial functions are totally differents. If you want to use MT4, you have to code in mql4 language. Regards.
To add comments, please log in or register