Autotrading keeps turning off

IdiotTrader  

Hi traders,

I just started renting an EA for MT4 platform. It required the Autotrading to be active. I click this, all is good. It turns green.
Then I synchronize everything with my MQL5 VPS that I rented.

Now autotrading turns off. In the journal I see "Virtual Hosting: XXXXX automated trading disabled after migration" 
I have tested it without running any EA, but the result is the same.
Does anyone have an idea on how to fix this?

Platform: MT4
Broker: ICMarkets
VPS: MQL5 Rented

Cheers 

Stanislav Korotky  
As soon as you start your copy of MT in VPS, your local copy of MT does automaticaly disable trading. This is done intentionally in order to prevent doubled ("mirrored") trades.
IdiotTrader  
Stanislav Korotky:
As soon as you start your copy of MT in VPS, your local copy of MT does automaticaly disable trading. This is done intentionally in order to prevent doubled ("mirrored") trades.
Hm, alright. But once I close my MT4, the VPS still doesn't allow autotrading, since it wasn't set up for that.
Is there any way to bypass this problem? Except for renting a VPS elsewhere.
IdiotTrader  
Daniela Bluemel:

it IS enabled when you turn off your MT4

the message means that VPS disabled automated trading on your MT4 

Thanks for your reply.
So basically what you are saying is that the VPS disabled automated trading on my MT4, so that it doesn't doubletrade? And that the VPS automated trading will still be active after I close my MT4 (even though it says disabled)?
Stanislav Korotky  
IdiotTrader:
Thanks for your reply.
So basically what you are saying is that the VPS disabled automated trading on my MT4, so that it doesn't doubletrade? And that the VPS automated trading will still be active after I close my MT4 (even though it says disabled)?

On the VPS hosted MT, automatic trading is always ON. The VPS hosted copy of MT keeps running even when your local copy is shutdown. 'Disabled' is related to the local copy as far as you quote local MT logs.

BTW, you can view VPS logs using context menu command "Journals" for your hosted copy of MT.

Pro4ex1  
i am running an EA but mt4 AUTO TRADING option automatically gets turned off. can anyone guide what can be the solution.
Ítalo Romani  
Pro4ex1 #:
i am running an EA but mt4 AUTO TRADING option automatically gets turned off. can anyone guide what can be the solution.


Did you solve your problem? I was getting bugged by Auto Trading being disabled in the same situation. Now using MetaTrader5 Version 5.0 build 3104.

It totally makes sense that AutoTrading gets disabled in the terminal once the EA is on the VPS. However, the way this logic is presented in the MT5 terminal interface is confusing. 

Once you attach your EA to a chart, you have to make sure that the EA's Algo Trading property is enabled. You can do this in the confirmation window when it starts, or finding this option in the popup menu, when right-clicking on the EA once is started. 

Then, you click on the VPS icon, which can be either stopped or running, and, in the popup menu, click to synchronize experts. Then, your EA icons must be greyed out, and the "Algo Trading" large button on the top panel will show a "stop" (red square) icon, saying that Algo Trading is disabled on the client. Fair enough, Algo Trading should be enabled on the VPS side.

This logic is perfect except for a small catch that I found. If the EA shows a MessageBox in the initialization, or the property script_show_input or script_show_confirm is enabled in your EA, the EA will fail to initialize on the server side without any traceable notice. I had a few MessageBox confirmations in my EA, and when I removed this and the script_show_input property, it solved my problem.

If you do a test by synchronizing the EA (with Algo Trading checkbox enabled) with the VPS, and then disconnecting from the network, you will see the client-side EA failing and, after re-connecting, you can check its log (with Print messages, if you used them) on the server side. To do this, right-click on the server icon and click on Journals. Then, selecting the option "Experts", you will find the log messages generated on the server side.

I hope this helps. 

Reason: