Tester agent issus: Local Network Farm doesn't work

To add comments, please log in or register
Xiangdong Guo
4558
Xiangdong Guo  

Setup PC-A/B/C in same local network (192.168.0.xxx), all PC are running Windows 10 64-bits, MT5 build 1241.

Setup Tester Agents service on PC-A, PC-B, ensure service is started and listening ports.

From PC-C, add agent via scan or manually, but didn't work anyway.

Shell I add some firewall rules on OS level?

Alain Verleyen
36674
Alain Verleyen  
Xiangdong Guo:

Setup PC-A/B/C in same local network (192.168.0.xxx), all PC are running Windows 10 64-bits, MT5 build 1241.

Setup Tester Agents service on PC-A, PC-B, ensure service is started and listening ports.

From PC-C, add agent via scan or manually, but didn't work anyway.

Shell I add some firewall rules on OS level?

Yes.
Gary Niemand
4002
Gary Niemand  

Hi,

I have a similar issue.... PC-A(desktop , lan cable to wifi router) can use the agents from PC-B(laptop wifi connected) , but PC-B cant use PC-A's agents???

I have opened the firewalls on both PCs on our private network.

This has worked before, but that was before Windows 10!

Any ideas/suggestions would be appreiated.


Thanx

aknetmma
57
aknetmma  
Hi similar issues I have encountered during window's update.
Mostly on windows 10, it updates and the settings got fucked up for a reason.

If the computer cannot be connected something's wrong either with the IP(static IP) or with the firewall.

If the computer on Farm is detected and executes insanely fast the tasks, then uninstall the services from the computer and reinstall them.

Bobby Koteski
19
Bobby Koteski  
Gary Niemand:

Hi,

I have a similar issue.... PC-A(desktop , lan cable to wifi router) can use the agents from PC-B(laptop wifi connected) , but PC-B cant use PC-A's agents???

I have opened the firewalls on both PCs on our private network.

This has worked before, but that was before Windows 10!

Any ideas/suggestions would be appreiated.


Thanx

I was having the same issue as you.

 SOLUTION: 

1. Set your PC/Laptop as discoverable on the network!

2. Create "inbound" rules for the ports that you are using. Windows Firewall > Advanced Settings > Inbound Rules > New Rule ...

You should now be able to use your agents from both machines.
To add comments, please log in or register