Download MetaTrader 5

System requirement for MT5 ?

To add comments, please log in or register
Manage agents in your profile. It is easy!
Florent
183
Florent 2015.11.20 16:58 
Hello, I have found nowhere operating system requirement for MT5, any idea ? Windows 7 consumes a lot or ressource in a VM under Ubuntu... please help. I need a solution to access the market place under Linux.
To add comments, please log in or register