Download MetaTrader 5

Metatrader 4 indicator only applying to 3 periods

To add comments, please log in or register
Publish your programs in the Market. Make money with your knowledge!
rush1884
20
rush1884 2015.08.05 13:49 

I was wondering if someone could help. I am using MetaTrader 4 for the first time and I am having some problems with some indicators I am trying to use.

I have got the squeeze break indicator attached to my chart. However it will only apply this indicator onto the last 3 periods (of any time frame - 3 one hour periods, 3 one day periods, 3 one month periods - as seen in picture). This problem doesn't seem to occur with the standard indicators and what is funny is that 2 hours ago the indicators were working fine, and being applied to all previous periods.

Any help would be great


Tan Phan Ngoc
1332
Tan Phan Ngoc 2015.08.05 13:59  
rush1884:

I was wondering if someone could help. I am using MetaTrader 4 for the first time and I am having some problems with some indicators I am trying to use.

I have got the squeeze break indicator attached to my chart. However it will only apply this indicator onto the last 3 periods (of any time frame - 3 one hour periods, 3 one day periods, 3 one month periods - as seen in picture). This problem doesn't seem to occur with the standard indicators and what is funny is that 2 hours ago the indicators were working fine, and being applied to all previous periods.

Any help would be great


If it works fine, no need to discuss.
rush1884
20
rush1884 2015.08.05 14:19  

I understand your point Tan Phan Ngoc, that all I'm looking for is a movement from red to green and 3 periods is enough, however I want to back test it and this obviously doesn't allow me to do it.

I you could possibly suggest a solution so that the indicator works on the whole graph it would be much appreciated.

rush1884
20
rush1884 2015.08.05 19:01  


It seems that the indicator wants to work sporadically now but just with this currency pairing? Again anyone with any suggestions as to how I can get the indicator working across the whole graph?

agan007
7
agan007 2015.08.06 01:28  
rush1884:


It seems that the indicator wants to work sporadically now but just with this currency pairing? Again anyone with any suggestions as to how I can get the indicator working across the whole graph?

 Go to see this topic:https://www.mql5.com/en/forum/62182

 maybe it's because Build 851..... 

Build 851 not bringing in all the indicators
Build 851 not bringing in all the indicators
  • www.mql5.com
Have just updated to Build 851 from Build 845 and it has not bringing in my custom indicators. - - Category: general
rush1884
20
rush1884 2015.08.06 07:05  

Thank you very much agan07.

I have got a short term fix for this now which I have posted in the thread you have outlined, hopefully it will help others as well - it basically entails uninstalling and then reinstalling metatrader4 and then not allowing permission to the client terminal to make software updates

To add comments, please log in or register