Download MetaTrader 5
To add comments, please log in or register
Trade like successful traders - subscribe to their signals!
Giraphant
21
Giraphant 2015.07.02 16:51 

Hi everyone,

Older version of MetaTrader 4 worked fine with Wine under Ubuntu. However since my broker update to build 840 I can not install it. I tried couple different brokers and get same error.

Here are software versions I am using:

- Ubuntu 15.04 64bit

- Wine 1.7.44


When I try to install it I am asked to specify proxy server. I don't use proxy. 


 

 If in the previous dialog I press "cancel" or put localhost as proxy server then it will try to download but progress bar will show 0% all the time with no error


 

Here is console output:

username@laptop:~/Desktop$ wine meta_trader_setup.exe

fixme:ver:GetCurrentPackageId (0x65e9d8 (nil)): stub

fixme:iphlpapi:SendARP (DestIP 0x0100a8c0, SrcIP 0x00000000, pMacAddr 0x65d4f0, PhyAddrLen 0x65d4e8): stub

err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.

 

When I install same version of MetaTrader under Windows 8.1 inside Virtualbox (with same Ubuntu as host operating system) it will work just fine.

Did any of you could make new MetaTrader 4 work under Wine? I would appreciate your help very much.


To MetaTrader creators: It is shame you won't make Linux version of your great software. At least you could make sure it works with Wine before releasing new version.

Yuda Prastyo
533
Yuda Prastyo 2015.07.02 17:27  
thank very much more article your post
Marco vd Heijden
Moderator
4073
Marco vd Heijden 2015.07.02 17:46  
Wine needs two more library's to be present for it to work but i forgot what they are i guess that doesn't help much but you could try to find out what they are and install the missing elements i have also done so int the past.
joseaio
5
joseaio 2015.08.15 19:32  

Multiples POSTs on Internet describes same error with ubuntu 15.04 (in my case also 64 bit)...

     Are you sure that cause are missing libraries? Can you help us indicating missing libraries?

Thank you in advance 

Marco vd Heijden
Moderator
4073
Marco vd Heijden 2015.08.15 20:22  

Yes Gecko and Mono Package, also maybe not missing, but wrong version (if you get the proxy window)


https://c.mql5.com/3/71/snapshot1.png

https://c.mql5.com/3/71/snapshot3.png

diaevd
9
diaevd 2015.11.07 01:31  
Giraphant:

Hi everyone,

Older version of MetaTrader 4 worked fine with Wine under Ubuntu. However since my broker update to build 840 I can not install it. I tried couple different brokers and get same error.

Here are software versions I am using:

- Ubuntu 15.04 64bit

- Wine 1.7.44


When I try to install it I am asked to specify proxy server. I don't use proxy. 


 

 If in the previous dialog I press "cancel" or put localhost as proxy server then it will try to download but progress bar will show 0% all the time with no error


 

Here is console output:

 

When I install same version of MetaTrader under Windows 8.1 inside Virtualbox (with same Ubuntu as host operating system) it will work just fine.

Did any of you could make new MetaTrader 4 work under Wine? I would appreciate your help very much.


To MetaTrader creators: It is shame you won't make Linux version of your great software. At least you could make sure it works with Wine before releasing new version.

 

You can see what's happening by strace.

Metatrader4 in wine trying to load library libgnutls.so.26 for i386.

Just do ln -vs /usr/lib/i386-linux-gnu/libgnutls-deb0.so.28 /usr/lib/i386-linux-gnu/libgnutls.so.26

(change libgnutls-deb0.so.28 to library in your system (ls -l /usr/lib/i386-linux-gnu/libgnutls*)). That's all.

 

for Metatrader5 you need to create a similar link for i686 in x86_64-linux-gnu folder.

johnnykraken
7
johnnykraken 2015.12.11 08:43  
diaevd:

 

You can see what's happening by strace.

Metatrader4 in wine trying to load library libgnutls.so.26 for i386.

Just do ln -vs /usr/lib/i386-linux-gnu/libgnutls-deb0.so.28 /usr/lib/i386-linux-gnu/libgnutls.so.26

(change libgnutls-deb0.so.28 to library in your system (ls -l /usr/lib/i386-linux-gnu/libgnutls*)). That's all.

 

for Metatrader5 you need to create a similar link for i686 in x86_64-linux-gnu folder.

Hello,

I've got same problem with MT5. I made what you wrote with library, but that doesn't work and terminal write this error:

err:secur32:SECUR32_initSchannelSP TLS library not found, SSL connections will fail

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.


Could you help me?

Really big thanks

Twan Jansbeken
143
Twan Jansbeken 2016.02.02 00:08  
diaevd:

 

You can see what's happening by strace.

Metatrader4 in wine trying to load library libgnutls.so.26 for i386.

Just do ln -vs /usr/lib/i386-linux-gnu/libgnutls-deb0.so.28 /usr/lib/i386-linux-gnu/libgnutls.so.26

(change libgnutls-deb0.so.28 to library in your system (ls -l /usr/lib/i386-linux-gnu/libgnutls*)). That's all.

 

for Metatrader5 you need to create a similar link for i686 in x86_64-linux-gnu folder.


Thanks diaevd, with some googling around based on your suggestions I managed to figure out what I have to do in my system.

Since it took me a while to get it all together I like to inform all others here about my findings:


So Metatrader appearantly tries to use library /usr/lib/i386-linux-gnu/libgnutls.so.26

However the lib version included with Ubuntu is now libgnutls-deb0.so.28.41.7

With a link we can make MetaTrader think it found the right lib. In my case the command line was:

sudo ln -vs /usr/lib/i386-linux-gnu/libgnutls-deb0.so.28.41.7  /usr/lib/i386-linux-gnu/libgnutls.so.26

The sudo command is needed to switch temporarily to root-user


Now, in my case the link seems correct, but Metatrader 4 is still complaining about the proxy. Any ideas how to proceed from here?

31337 Investments Ltd.
767
Rafal Wieczorek 2016.06.12 23:34  
It's not a bug in libgnutls, it's simply missing SSL library, since it's downloading the files from HTTPS sites. Install winetricks and run:
winetricks winhttp
to install it.
mschoenebeck
7
mschoenebeck 2016.08.05 11:52  
Rafal Wieczorek:
It's not a bug in libgnutls, it's simply missing SSL library, since it's downloading the files from HTTPS sites. Install winetricks and run:
winetricks winhttp
to install it.

Thanks a lot! That did the trick with the proxy window stuff...

But now I have another problem. After the download start I get this error after a few minutes.. No error message in terminal and no other info... any suggestions?

Error while downloading

Marco vd Heijden
Moderator
4073
Marco vd Heijden 2016.08.05 11:54  
mschoenebeck:

Thanks a lot! That did the trick with the proxy window stuff...

But now I have another problem. After the download start I get this error after a few minutes.. No error message in terminal and no other info... any suggestions?


Which error?

Necessary packages are Gecko and Mono.

/ /12
To add comments, please log in or register