Enabling 2FA/TOTP in the desktop terminal

 
Hi all, I cant see the option for 2FA/TOTP on the desktop. I right click on my demo account and can see login ect but not the 2FA option. Any ideas?
Will this work on demon too?
Reason: