Download MetaTrader 5

Weird behavior for moving average!

To add comments, please log in or register
Karim El Bawab
183
Karim El Bawab  

Dear All,

 I've many accounts in different brokers who are using metatrader 4. Lately, I've added the 55-moving average on one chart however, I can see that both charts are putting the 55-moving average in different places! However, it is the same period of chart (4H) and the same pair and the same setting for the moving average!

 Can this happen because every chart has different history margin? (one chart have 10 years history while the other has 20 years history?). How can I make sure that the moving average I am using is perfectly correct as every one sees?

 Thanks a lot 

Alain Verleyen
Moderator
32008
Alain Verleyen  
kokillennium:

Dear All,

 I've many accounts in different brokers who are using metatrader 4. Lately, I've added the 55-moving average on one chart however, I can see that both charts are putting the 55-moving average in different places! However, it is the same period of chart (4H) and the same pair and the same setting for the moving average!

 Can this happen because every chart has different history margin? (one chart have 10 years history while the other has 20 years history?). How can I make sure that the moving average I am using is perfectly correct as every one sees?

 Thanks a lot 

Can you see post screenshots to demonstrate what you mean exactly. Also, which settings are you using for your MA, is it a SMA ? or ?
Karim El Bawab
183
Karim El Bawab  
angevoyageur:
Can you see post screenshots to demonstrate what you mean exactly. Also, which settings are you using for your MA, is it a SMA ? or ?

I can tell you the setting and the chart and you try it by yourself, since I'll not be able to share a screen shot at the moment.

 Chart EURUSD (DAILY) - Insert > indicators > Trend > moving average > MA METHOD: SIMPLE : Period: 55 : APPLY to: CLOSE

You will find it NOW around 1.23649

 In different broker using the SAME exact setting, 55-moving average is at: 1.23166

 This is VERY weird and annoying issue for me!

Daniel Stein
29808
Daniel Stein  
kokillennium:

I can tell you the setting and the chart and you try it by yourself, since I'll not be able to share a screen shot at the moment.

 Chart EURUSD (DAILY) - Insert > indicators > Trend > moving average > MA METHOD: SIMPLE : Period: 55 : APPLY to: CLOSE

You will find it NOW around 1.23649

 In different broker using the SAME exact setting, 55-moving average is at: 1.23166

 This is VERY weird and annoying issue for me!

 

Different brokers use different timezones so check your Market Watch.

From M1-H1 you'll see the same data and candles on all brokers but from H4 upwards it's different because the candles open and close at different GMT timestamps which results in different HLOC data and indicator calculations. 

Karim El Bawab
183
Karim El Bawab  
blueball:

 

Different brokers use different timezones so check your Market Watch.

From M1-H1 you'll see the same data and candles on all brokers but from H4 upwards it's different because the candles open and close at different GMT timestamps which results in different HLOC data and indicator calculations. 

Then, How can I adjust this setting to make sure that my moving averages are correct?
Alain Verleyen
Moderator
32008
Alain Verleyen  
kokillennium:
Then, How can I adjust this setting to make sure that my moving averages are correct?

If the problem is what Daniel said, there is nothing you can do, except use brokers with the same server time.

But is it the problem ? That's why I asked you to share screenshots.

Karim El Bawab
183
Karim El Bawab  
seems that Daniel words are correct. Thanks a lot. If any one have another reason, please share
To add comments, please log in or register