virtual server not delivering notifications from my custom indicators - page 2

Kingsley Okhumoide Idomeh
238
Eleni Anna Branou:

We couldn't know if we don't see your MQL5 VPS Journals or your indicator's code. Are your indicators MQL5 VPS compatible?

MQL5 VPS does not allow DLL calls, so if they require DLL they will not work properly.

Have you contacted the indicators author/seller or your presume that its MQL5 VPS's fault?

Have you used your indicators locally on your MT4/5 terminal, without MQL5 VPS to check if they work as they should and if they send push notifivations?

Hi Eleni, 


Thanks for your prompt response.

Answer to all your questions are Yes. DLL is was disable prior to migration. it showed in the journal that my indicators were loaded and also migration processed. 

I have been using all my indicators successfully with PUSH notifications prior to the VPS, I only wanted to get notifications when my system is offline or shutdown. 


Thanks.

Keith Watford
Moderator
36151
KINGS:

you are busy focusing on my upper case.....yet have no solution to the issue!

Sigh!

Keith Watford:

This is a users' forum. This is not Metaquotes support, we users cannot always answer every question. Please be polite and somebody that has experienced the issue may be able to help you..

Juvenille Emperor Limited
Moderator
33374
KINGS:

Hi Eleni, 


Thanks for your prompt response.

Answer to all your questions are Yes. DLL is was disable prior to migration. it showed in the journal that my indicators were loaded and also migration processed. 

I have been using all my indicators successfully with PUSH notifications prior to the VPS, I only wanted to get notifications when my system is offline or shutdown. 


Thanks.

If the indicators are coded correctly and send puch notifications locally, they should send through MQL5 VPS too, as long as they don't require DLL.

So, something is not working as it should and that is not MQL5 VPS.

Kingsley Okhumoide Idomeh
238
Eleni Anna Branou:

If the indicators are coded correctly and send puch notifications locally, they should send through MQL5 VPS too, as long as they don't require DLL.

So, something is not working as it should and that is not MQL5 VPS.

Yes, that's what I expected. I would keep trying.....hopefully it works!


Thanks for the pointers. 

Keith Watford
Moderator
36151
Comments that do not relate to this topic, have been moved to "Off Topic Posts".
Carlos Thomas
138
Carlos Thomas  

Good night all. Hijacking this thread with a similar issue. Not sure if it's related or not.

Primary phone has my MQID that I've been using for some time now. All was working up until a few days ago then I suddenly stopped getting notifications. Thought it was VPS or broker server - but notifications work when tested on secondary phone. So I'm confused. Any ideas?

On the OPs question. I'm not sure if the signals work on the MQL VPS. That doesn't usually allow for certain indicators or EAs to work. If it's a VPS from some third-party vendor that's actually running Windows - then anything should work.

*EDIT*
For my own issue. Clearing cache and data for the app fixed the issue. I'll probably post a solved thread with the information.