Problem with some ex4 indicators no longer working in MT4

Arecibo
114
Arecibo  
I have recently switched my VPS host and when I loaded the MT4 onto the new server and transferred my indicators folder across I have limited ex4 indicators working. It seems random as some work but others not. My 2 custom EA's also do not work. When I drag them to chart the error message in the Journal reads "cannot load C:Users/Administrator...etc. My previous VPS server ran them all flawlessly as does my pc so I have no idea what has changed.
Juvenille Emperor Limited
Moderator
17961
Eleni Anna Branou  
Arecibo:
I have recently switched my VPS host and when I loaded the MT4 onto the new server and transferred my indicators folder across I have limited ex4 indicators working. It seems random as some work but others not. My 2 custom EA's also do not work. When I drag them to chart the error message in the Journal reads "cannot load C:Users/Administrator...etc. My previous VPS server ran them all flawlessly as does my pc so I have no idea what has changed.

If this is not about MQL5 VPS, contact your VPS provider.

Arecibo
114
Arecibo  
Eleni Anna Branou:

If this is not about MQL5 VPS, contact your VPS provider.

Apologies, this is not about my VPS but about MT4, I was merely setting the scene for variables. This is an issue with how the MT4 is recognising the EX4 files.

Fernando Morales
4877
Fernando Morales  
Arecibo:

Apologies, this is not about my VPS but about MT4, I was merely setting the scene for variables. This is an issue with how the MT4 is recognising the EX4 files.

Do your EAs load indicators using hard coded pathnames?

Arecibo
114
Arecibo  
Fernando Morales:

Do your EAs load indicators using hard coded pathnames?

Apologies, I'm not sure what you mean. It seems completely random as to which custom indicators work and which do not. 

Daniel Stein
107119
Daniel Stein  
Arecibo:

Apologies, I'm not sure what you mean. It seems completely random as to which custom indicators work and which do not. 

If your terminal or EA is unable to load specific ex4 files it's

1. either a problem of a wrong pathname or link inside the custom EA or

2. an issue with the user rights for the requested folder


Every MT4 terminal creates it's own data folder in your user profile but the user profile do have individual names (Windows IDs) with specific user rights.

Instead of copying the entire indicator folder I recommend copying all relevant indicators from the old VPS terminal data folder to the new data folder at the new VPS.

Arecibo
114
Arecibo  
Daniel Stein:

If your terminal or EA is unable to load specific ex4 files it's

1. either a problem of a wrong pathname or link inside the custom EA or

2. an issue with the user rights for the requested folder


Every MT4 terminal creates it's own data folder in your user profile but the user profile do have individual names (Windows IDs) with specific user rights.

Instead of copying the entire indicator folder I recommend copying all relevant indicators from the old VPS terminal data folder to the new data folder at the new VPS.

Thanks for your reply Daniel. I have tried this and oddly some indicators that did not work before are now working, but there are some that are still not. Both of my EA's are still not working, the one is custom time frame generator that needs no other indicators to work and the other is a trading bot using 3 indicators, one of which is working and the other 2 not.

I have tried individually transferring the indicators one by one from both my old VPS and my PC MT4 "indicators" folder. both had the same effect of some working and others not.