Warning - ex5 is not 64-bit version ?

0xA0B1 FX5
118
0xA0B1 FX5  

Hello,


I got this odd warning with build 2174 during beginning of the backtest:


2019.10.14 06:18:12.405 FX5 'C:\Users\Administrator\AppData\Roaming\MetaQuotes\Terminal\E23367DD11DBEB0EF97D08185EAB7295\MQL5\Experts\EA\FX5.ex5' is not 64-bit version


I did recompile the EA with the latest build of the editor, and still the same warning when I start the backtest .. OS is of course Windows x64 and proper MT5 ;)

Alain Verleyen
41565
Alain Verleyen  

Please show what is in your log (Journal tab of Toolbox window).

2019.10.12 10:13:02.385    Terminal    MetaTrader 5 x64 build 2171 started (MetaQuotes Software Corp.)
2019.10.12 10:13:02.393    Terminal    Windows 10 (build 18362) x64, IE 11, UAC, Intel Core i5-3317U  @ 1.70GHz, Memory: 3436 / 7893 Mb, Disk: 179 / 464 Gb, GMT-5

0xA0B1 FX5
118
0xA0B1 FX5  
2019.10.14 17:45:57.146 Terminal ICMarkets - MetaTrader 5 x64 build 2174 started (International Capital Markets Pty Ltd.)
2019.10.14 17:45:57.149 Terminal Windows Server 2016 (build 17763) x64, IE 11, UAC, Intel Core i7-2720QM  @ 2.20GHz, Memory: 5691 / 16267 Mb, Disk: 135 / 476 Gb, GMT+0


winver:

Windows Server 2019 Version 1809 OS Build 17764.805

Alain Verleyen
41565
Alain Verleyen  
0xA0B1 FX5:
2019.10.14 17:45:57.146 Terminal ICMarkets - MetaTrader 5 x64 build 2174 started (International Capital Markets Pty Ltd.)
2019.10.14 17:45:57.149 Terminal Windows Server 2016 (build 17763) x64, IE 11, UAC, Intel Core i7-2720QM  @ 2.20GHz, Memory: 5691 / 16267 Mb, Disk: 135 / 476 Gb, GMT+0


winver:

Windows Server 2019 Version 1809 OS Build 17764.805

Is this Windows Server 2016 or 2019 ?

Maybe due to Windows Server 201X. Can you try with Windows 10 on an other computer ? (Compile there then run on your Windows Server).

0xA0B1 FX5
118
0xA0B1 FX5  

Hello Alain,


its 2019. The warning came up with the last beta builds, if I remember with 2170 (main release) there was no such warning. 

Currently I have no Win10 instance available. The EA works just fine, so I assume the warning is a new "feature" ..

MILAD NAJJARI
238
MILAD NAJJARI  

hello everyone ;

i have this error in expert tab of my terminal MT5 ,  anyone help me what should i do ? is there any way to fix this ?


2020.12.27 01:20:07.548    dz    'C:\Users\Milad\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Libraries\dynamicZone.dll' is not 64-bit version
2020.12.27 01:20:09.978    dz (EURUSD,M1)    Cannot load 'C:\Users\Milad\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Libraries\dynamicZone.dll' [193]