MT4 overwriting two files metaeditor.exe and terminal.exe does not work anymore?

To add comments, please log in or register
miky
201
miky  
I do use /portable  mode on MT4 (multiple instances), and do try to update today just by overwriting two files metaeditor.exe and terminal.exe with newer versions from resent build. And for some reason MT4 can not connect even with new builds. Anyone having similar issues?
lippmaje
1048
lippmaje  

Maybe your build is too old. From March 1st on some older builds are not allowed to connect to the trading server.

https://www.mql5.com/en/forum/302371

Support for older MetaTrader 4 Desktop and Android versions to end on March 1, 2019
Support for older MetaTrader 4 Desktop and Android versions to end on March 1, 2019
  • 2019.02.06
  • www.mql5.com
After 1 March 2019, MetaTrader 4 desktop terminal builds below 1118 and MetaTrader 4 Android terminals below 1104 will no longer be supported...
miky
201
miky  
Just now noticed in "Journal" tab there is some sort error "MQL Base: failed write to base" . Some time ago , have been editing "folder permissions" of C:\Users\mike\AppData\Roaming\MetaQuotes\WebInstall to avoid unnecessary updates. It worked fine with old MT4 builds, but builds from 1118 do needs some sort of different-default folder permissions. 
lippmaje
1048
lippmaje  
Upgrading by merely swapping executables is not the best practice...
nicholi shen
2392
nicholi shen  
I wrote a utility to automatically installs multiple terminals in a portable directory and simlinks the [MQL, history, Sounds, templates] directories so a change in one syncs to all. Using this method allows the terminals to update themselves without the risk of messing up everything. https://gitlab.com/nicholishen/Vanilla-MT4/blob/master/Vanilla-MT4-v0_0_2.zip
Nick / Vanilla-MT4
Nick / Vanilla-MT4
  • 2018.08.12
  • gitlab.com
A vanilla copy of MT4 with setup scripts to run in portable mode and clone terminals for all kinds of reasons.
To add comments, please log in or register