Download MetaTrader 5
To add comments, please log in or register
Create interesting Forum topics concerning the automated trading!
bruno
35
bruno 2010.10.23 00:39 

Yesterday where I live there was a power outage, and my pc turned off suddenly.MT5 was opened at the time.

Since then, now when I launch my MT5, I get the message 'server base corrupted' in the log tab of the bottom area of the window.

I'm am not able to connect. I am requested my demo trading account login informations, i enter them, but I'm not able to enter the server information,

they seem to have been lost.A network rescan is performed on the port 443, searching for servers, but no server is found.

I have always had  a firewall installed with no problems, I mention this because it could be a potential issue.

Where  can I get the server information of the MT5 default demo account ?

Thank you

bruno 

 

Alexey Da
Moderator
6562
Alexey Da 2010.10.25 18:35  
Try to do these actions:

   1. Close terminal.
   2. Remove file servers.dat in config folder
   3. Start terminal again

After that you should be able to open new demo account or login using your old account data.

If you don't, you better remove your terminal and then install it from setup file.
Documentation on MQL5: Standard Constants, Enumerations and Structures / Environment State / Account Properties
  • www.mql5.com
Standard Constants, Enumerations and Structures / Environment State / Account Properties - Documentation on MQL5
bruno
35
bruno 2010.10.26 01:03  

Thank you so much! alexvd, it worked again by removing file servers.dat, I am now logging back again with my old account data.

bruno 


bruno
35
bruno 2010.11.03 02:58  

Just to stay on the subject, I also have installed MT4 on my notebook PC with Windows Vista.

When i installed MT4, I installed it as administrator, but normally I do normal operation on my

default non-administrator account. As per the above problem solved with MT5, in MT4 I have a similar

one, that is, when I start MT4 as administrator account the connection with the servers work,

when I launch MT4 as my non-administrator account, the connection with the servers does not work.

I noticed that MT4 installation is different from MT5's, in that configuration and other files seem to be all  

under the subfolders in C:\program files\MetaTrader 4, there is no servers.dat file,but different ones,

for example in the config subfolder I have server.ini, Tadawulfx-Demo.srv, IBFXAU-MT4-ID01.srv among

others, they are not in readable form. I would like to make connection work when launching MT4 from

my standard account, because there I have all templates, profiles, custom indicators etc.

I also gave full controll permissions to my standard user to the folder hierarchy under C:\program files\MetaTrader 4,

but the problem persists. Is there a solution (also maybe I must install MT4 ALSO for my current

non administrator user, would it work ?, and so on). As a last resort, I would manually apply each of my

current templates, profile charts and indicators while running MT4 as administrator, but first I want to check

if there is a cheaper alternative. 

Thank you for help

bruno 

Alexey Da
Moderator
6562
Alexey Da 2010.11.05 10:20  

You have 2 ways to solve this problem:

  1. You can turn off UAC in Vista
  2. You can run MT4 as administrator using "Run as Administrator" command of context menu
Alexey Da
Moderator
6562
Alexey Da 2010.11.05 11:13  

You can also read this topic in MQL4 forum.

https://www.mql5.com/en/forum/112576 

where are MY files (EA. templates,..) ?? - MQL4 forum
  • www.mql5.com
where are MY files (EA. templates,..) ?? - MQL4 forum
bruno
35
bruno 2010.11.05 12:05  

So Alexvd, in order to have connection work, I'm forced to  run MT4 running it as administrator,

without any chance to run it as my current 'normal' user, right ?

 thank you

/
To add comments, please log in or register