Download MetaTrader 5

MT4 not auto connecting after ping fail

To add comments, please log in or register
Ivo Luhse
726
Ivo Luhse  

Hi guys and gals ;)

I'm having big trouble with MT4 connection issues.

I run multiple MT4's on a dedicated server with low latency to my brokers 1-2 milliseconds. However, quite often (1-2 times a day) MT4 keeps dropping the connection. Now, most of the time it will reconnect back within a second which fine but there are times when MT4 will not reconnect automatically and will just stop with red connection bars and "no connection" on the bottom right. And even if I re-scan the servers or try to login again it will do nothing. Only way to reconnect is by restarting the MT4

Anyone else has this problem?

Is there any way to force MT4 to reconnect via EA or script?

It's driving me crazy to see my MT4 drop connection when my EA's should be working. 

Any help would be much appreciated

PS.It doesn't look like a broker issue because I get the same error from 2 different brokers.

Eleni Anna Branou
Moderator
4853
Eleni Anna Branou  
Ivo Luhse:

Hi guys and gals ;)

I'm having big trouble with MT4 connection issues.

I run multiple MT4's on a dedicated server with low latency to my brokers 1-2 milliseconds. However, quite often (1-2 times a day) MT4 keeps dropping the connection. Now, most of the time it will reconnect back within a second which fine but there are times when MT4 will not reconnect automatically and will just stop with red connection bars and "no connection" on the bottom right. And even if I re-scan the servers or try to login again it will do nothing. Only way to reconnect is by restarting the MT4

Anyone else has this problem?

Is there any way to force MT4 to reconnect via EA or script?

It's driving me crazy to see my MT4 drop connection when my EA's should be working. 

Any help would be much appreciated

PS.It doesn't look like a broker issue because I get the same error from 2 different brokers.


Then its a VPS server issue.

You should try on a different VPS, MQL5 MT4 integrated one never failed me.

Meng Yin Teoh
1813
Meng Yin Teoh  
Ivo Luhse:

Hi guys and gals ;)

I'm having big trouble with MT4 connection issues.

I run multiple MT4's on a dedicated server with low latency to my brokers 1-2 milliseconds. However, quite often (1-2 times a day) MT4 keeps dropping the connection. Now, most of the time it will reconnect back within a second which fine but there are times when MT4 will not reconnect automatically and will just stop with red connection bars and "no connection" on the bottom right. And even if I re-scan the servers or try to login again it will do nothing. Only way to reconnect is by restarting the MT4

Anyone else has this problem?

Is there any way to force MT4 to reconnect via EA or script?

It's driving me crazy to see my MT4 drop connection when my EA's should be working. 

Any help would be much appreciated

PS.It doesn't look like a broker issue because I get the same error from 2 different brokers.


Get a VPS with hyper-V virtualization then you should be fine.
Ivo Luhse
726
Ivo Luhse  
Meng Yin Teoh:

Get a VPS with hyper-V virtualization then you should be fine.


Why do you think hyper V would solve this?

I run powerfull i7 7770K servers and my load is onlyat 20-30%

To add comments, please log in or register