MT4/206 issues

static
97
static  

Just though I would see if anyone else has this problem.

I have the standard non-branded MT4 terminal installed and an IBFX branded version of the client, both build 206. In my MT4 version, I can export backtest results and trade history normally. However in my IBFX version, this does not work. The dialog box comes up asking where to save, etc. etc. but after I click OK nothing happens.

I had the same problem before with exporting tick data from the history center, but the problem just fixed itself one day and I have no idea how. Has this happened to anyone else, and if so how did you fix it?

[Deleted]  

I have sometimes that exporting the trade history does not work the first time, but will when retrying. However, I've had this also with earlier versions than 206 and other brands than IBFX. In my case it may have to do with the fact that I save on a network drive. Other than the branding, the versions of MetaTrader are all the same as far as I know.

I guess you could simply try to replace the IBFX executable (terminal.exe) with the generic one (after making a backup copy of the IBFX one first) and see what happens. Information about accounts and servers are in configuration files, so it should work.

If this sounds scary, simply make a copy of the installation directory to experiment with. That way it's also easy to do comparisons.

static
97
static  

IBFX is trading live right now so I can't do it at the moment, but I did try an uninstall/reinstall last weekend to no avail. I'll give that a try on Friday after the markets close though, thanks for the advice.