Issue with receiving no new chart ticks for some symbols

To add comments, please log in or register
James Parker
997
James Parker  

Hi All,

My terminal has decided it doesn't want to receive new chart ticks or update the bid/ask prices in marketwatch for a few symbols. Yet it is connected to broker and the data for all other symbols is coming through fine. I also have another terminal running alongside it both with the same broker and all prices are updating perfectly on the other terminal. So I don't really understand what is going on in this terminal. They are both demo accounts running on MT4 build 1031 on a VPS server. The broker is FXCM and the symbols are the US30 and UK100.

It's like the price feed has just stopped for those two symbols, but only in one terminal. I've attached some images showing what I am seeing - 0 bid/ask in marketwatch and on the chart. ‌

Has anyone else had a similar issue before and know a possible fix?

Thanks.

 ‌

Files:
Alain Verleyen
36142
Alain Verleyen  

You should ask support to your VPS provider, and report this issue to Metaquotes ServiceDesk.

Check also the VPS ‌Task manager, is there free RAM/Disk ? What about internet connection ?

James Parker
997
James Parker  

Hi Alain,

Thanks for the response, I've just managed to resolve this with the brokers technical support in the end, had been on hold for while.

After some playing around data is now being received again :)

Alain Verleyen
36142
Alain Verleyen  
James Parker:

Hi Alain,

Thanks for the response, I've just managed to resolve this with the brokers technical support in the end, had been on hold for while.

After some playing around data is now being received again :)

Good. What was the problem ?
James Parker
997
James Parker  
Alain Verleyen:
Good. What was the problem ?

They said there is sometimes an issue with receiving data for lots of currency pairs in marketwatch at the same time, and recommended I keep the number of pairs down to below 30. I must have had it on "show all". We had to close all charts, hide and show all in market watch, and close and open the terminal a few times and eventually the data started coming through again.
Alain Verleyen
36142
Alain Verleyen  
James Parker:

They said there is sometimes an issue with receiving data for lots of currency pairs in marketwatch at the same time, and recommended I keep the number of pairs down to below 30. I must have had it on "show all". We had to close all charts, hide and show all in market watch, and close and open the terminal a few times and eventually the data started coming through again.
Ok so it's internet bandwidth. I would avoid such VPS if you are trading on a live account.
James Parker
997
James Parker  
Alain Verleyen:
Ok so it's internet bandwidth. I would avoid such VPS if you are trading on a live account.


Thanks, will look into switching VPS then. Is there any provider you would recommend?

The broker have just offered me a deal on their VPS, I guess it would be the fastest connection to their data but I always have suspicions about using any broker software in case it could be manipulated.‌

Alain Verleyen
36142
Alain Verleyen  
James Parker:


Thanks, will look into switching VPS then. Is there any provider you would recommend?

The broker have just offered me a deal on their VPS, I guess it would be the fastest connection to their data but I always have suspicions about using any broker software in case it could be manipulated.‌

We cannot recommend any commercial offer. But if you search carefully you will there are some holes in the rule ;-)
James Parker
997
James Parker  
Alain Verleyen:
We cannot recommend any commercial offer. But if you search carefully you will there are some holes in the rule ;-)

Thanks. I'll have a search around!
To add comments, please log in or register