Download MetaTrader 5

MT4 MetaEditor Hotkey Problems -- SOLVED

To add comments, please log in or register
Tim Barnard
Tim Barnard 2016.06.20 18:27 

I am running version 5.00 Build 1342 of the Metaeditor. Much of the editing capability does not work and I do not understand why.

Ctrl-A works properly and selects all of the lines of code and Ctrl-F does bring up the Find dialog box. But Ctrl-H does not work

properly. When I press it no dialog box appears, instead the buttons to maximize, minimize or close the file currently being edited

are grayed out and pressing any key simply causes a beep to be played as if the keyboard buffer was full or something. Has anyone

else experienced this problem? If so what did you need to do to correct it? Is there a way, other than doing a re-install of MT4, to

reset this functionality? 

Aleksey Pak
Aleksey Pak 2016.06.21 08:57  
Can't reproduce your issue. Provide more details: Windows version, source code, metaeditor language.
Tim Barnard
Tim Barnard 2016.06.21 18:21  
Can't reproduce your issue. Provide more details: Windows version, source code, metaeditor language.

I've done a bit more experimenting trying to figure this problem out. I've installed MT4 from another broker and don't have the problem there, so its not a Windows 10 taking Ctrl+H away issue.

I've also tried uninstalling my broker's MT4, then re-installing. Problem persists.

Also I've discovered that it's not locking up, instead its accessing the search function in the upper right-hand corner of Metaeditor, rather than bringing up the Find & Replace dialog box.

The strange thing is, whatever I type does not appear in that search box yet if I subsequently hit Enter it will search the script or Indicator for whatever I typed. If I then exit Metaeditor

and re-start it, what I typed for the search now appears in that search box in the upper right-hand corner. This is just bizarre behavior. What would cause Ctrl+H to re-map to access the

functionality of that search bar. It would make marginally more sense if for some reason Ctrl+F did that. Yet Ctrl+F works just fine.


I'm running Windows 10.

Metaeditor is version 5.00 build 1342

Language used is US English. 

Tim Barnard
Tim Barnard 2016.06.22 05:10  

Problem solved!!


This is a good case of not having sufficient information from MetaTrader / MQL5 Ltd and having to dig until you stumble across the solution.

 I have an 8 monitor trading station where all of the monitors act as one very large, seamless monitor. Top-left is 0, 0 and bottom-right

is 1080, 5760. At some point, and I do not know when this happens, Metaeditor saved to the config folder a metaeditor.ini file. This file

does not exist when you first install MT4. There were two entries in this file under the [Find] section that made no sense. Deleting those two

entries fixed the problem and Ctrl+H now works correctly. Those entries were:


Dlg_158_left = -54

Dlg_158_top = -1195


Shutting down Metaeditor, editing metatrader.ini with Notepad to remove those two lines, saving the modifications and then restarting Metaeditor corrected the problem.

To add comments, please log in or register